5 Replies Latest reply on Oct 6, 2017 11:37 AM by Abdul Moid Mohammed

    Issue accessing the Environment using Midtier - My IT /RSSO workfine

    Abdul Moid Mohammed

      Hi Team,

       

      We have upgraded one of our environment successfully - BMC Remedy ARS from 9.1.02 to 9.1.03 Patch001 successfully.

      We are with Oracle as OS and Windows as OS.

       

      We are facing issues login to ITSM/SRM through Midtier whereas the My IT with RSSO works fine.

       

      Appreciate response at your earliest availability.

       

      Regards;--Abdul Moid

        • 1. Re: Issue accessing the Environment using Midtier - My IT /RSSO workfine
          Christian Smerz

          After upgrading RSSO and after patching RSSO, I had to modify the web.xml on our midtier server.  Started working again.

          Modification of web.xml is the last step during integration of
          Remedy SSO with Remedy Mid Tier. If you encounter this issue, you can continue
          to complete Remedy Mid Tier integration by adding the following RSSO
          <filter> and <filter-mapping> in <MT>/WEB-INF/web.xml. Then,
          restart the Remedy Mid Tier Tomcat.

          Note

          When adding RSSO <filter-mapping>, make sure it is added as
          the first <filter-mapping> element in web.xml.

          ?

          <filter>

              <filter-name>RSSOFilter</filter-name>

              <filter-class>com.bmc.rsso.agent.RSSOFilter</filter-class>

          </filter>

           

          <filter-mapping>

              <filter-name>RSSOFilter</filter-name>

              <url-pattern>/*</url-pattern>

          </filter-mapping>

          • 2. Re: Issue accessing the Environment using Midtier - My IT /RSSO workfine
            Ravindrakumar Rodge

            Did you bypass your RSSO and test only with Midtier?

            Are you able to see RSSO admin console.

            Check the arjavaplugin.log at server side to see if you get any errors related to RSSO or AREA Plugins.

            What if you try using different clients like user tool, dev studio does it throws same errors. Just to isolate the problem area these test would be of good help.

             

            Regards,

            Ravi

            • 3. Re: Issue accessing the Environment using Midtier - My IT /RSSO workfine
              Abdul Moid Mohammed

              Yes the same setting is present in web.xml at my environment too.

               

              We have not upgraded RSSO ..its only the ARS Upgrade from 9.1.02 to 9.1.03 Patch001.

              • 4. Re: Issue accessing the Environment using Midtier - My IT /RSSO workfine
                Abdul Moid Mohammed

                Hi Ravi,

                 

                I dont see any issues connecting through user Tool ,Dev Studio and even My It works fine.

                When connecting from My IT to SRM/ITSM it throws errors.

                 

                Yes i have checked arjavaplugin and it throws the errors below.

                 

                <PLUGINSVR> <TNAME: pool-5-thread-14         > <ERROR> <ARPluginContext > < ARPluginContext.java:179       > /* Fri Oct 06 2017 09:34:30.668 */  <ARSYS.AREA.ATRIUMSSO>Login Failed as Atrium SSO Server Location is null

                <PLUGINSVR> <TNAME: pool-5-thread-14         > <ERROR> <ARPluginContext > < ARPluginContext.java:179       > /* Fri Oct 06 2017 09:34:30.668 */  <ARSYS.AREA.RSSO>[0] Failed to authenticate user abdul.moid with token, Token not obtained

                 

                I tried to follow Remedy ARS 8.1:<ARSYS.AREA.ATRIUMSSO>Login Failed which describes...

                "

                You can try by commenting out 'com.bmc.arsys.pluginsvr.plugins' entry in log4j_pluginsvr.xml. If there is any issue with other plugin logs then you can revert the changes.

                 

                If 'ARSYS.AREA.ATRIUMSSO' plugin entry is enabled in the 'pluginsvr_config.xml' file then plugin server will keep logging errors related to this plugin in the log file. So as suggested above, best and simple way to avoid this is comment out this plugin entry in 'pluginsvr_config.xml' file.

                 

                As stated earlier, you can get hotfix for this issue from BMC by providing defect Id.

                 

                But still i see the similar issue at our environment.

                 

                Appreciate response at your earliest availability.

                 

                • 5. Re: Issue accessing the Environment using Midtier - My IT /RSSO workfine
                  Abdul Moid Mohammed

                  Hi Everyone,

                   

                  Looks like the issue was with Non LDAP users so after checking things at other users and accessing the environment using LDAP Credentials things are back to normal with Environment at our end.

                   

                  Thanks;--Abdul Moid