1 2 Previous Next 15 Replies Latest reply on Jun 19, 2017 10:19 PM by Ricky R

    AR Email Messages Status Error

    Ricky R
      Share This:

      Hi All,

       

      I got this issue.

       

      So the ar email messages can run but more than half of the record is getting error  send message status.

       

       

      As you can see at the screenshot, it has 7095 but only 790 records is sent. I tried to see the error logs from the tab error on the records either in the email logs in the bmc ar system email but it show nothing. it's weird since some of it can send.

       

      Here is my mailbox configuration.

       

       

      Is there anything wrong in the email server, if yes what should i check at the email server or is the email server account need some configuration or there are configuration in bmc remedy i need to reset?

       

      Please advice.

       

      Regards

        • 1. Re: AR Email Messages Status Error
          Mohammad Rehman

          Have you checked the email engine logs? I will suggest to turn on the filter log and by resetting the error retry sending out and see?

          1 of 1 people found this helpful
          • 2. Re: AR Email Messages Status Error

            Hi Ricky,

             

            If 790 Messages are sent it means that configuration is correct, the only thing you need to check logs.

             

            Enabled Debug logging by following below steps

             

            Steps:

             

             

            1. To enable debug logs for email engine.

             

             

            2. Stop the email engine service from services.msc.

             

             

            3. Navigate to ARSystemInstallDir\AREmail\

             

             

            4. Locate the EmailStart.bat and make a copy of EmailStart.bat.

             

             

            5. Rename the copied file as EmailStart.bat.backup to preserve your original copy.

             

             

            6. Now edit the EmailStart.bat file in notepad.

             

             

            7. Locate the line which starts with java as shown below.

             

             

            Ex:

            "%JavaPath%\java" "%JAVA_OPTS%" -cp emaildaemon.jar;.;log4j-1.2.14.jar;arapi%LIBVER%.jar;arutil%LIBVER%.jar;activation.jar;mail.jar;imap.jar;smtp.jar;pop3.jar;armapi%LIBVER%.jar com.bmc.arsys.emaildaemon.EmailDaemon %*

             

             

            Change as below:

             

             

            "%JavaPath%\java" "%JAVA_OPTS%" –Dmail.debug=true -cp emaildaemon.jar;.;log4j-1.2.14.jar;arapi%LIBVER%.jar;arutil%LIBVER%.jar;activation.jar;mail.jar;imap.jar;smtp.jar;pop3.jar;armapi%LIBVER%.jar com.bmc.arsys.emaildaemon.EmailDaemon %* > C:\temp\output.txt

            Add

            –Dmail.debug=true

            > C:\temp\output.txt

            Save the file.

            Open command prompt -> Navigate to ARSystemInstallDir\AREmail\

            Type EmailStart.bat and press enter which will start email engine from command prompt in debug mode. (Minimize the window and keep it running).

            It will capture the logs in c:\temp\output.txt file.

             

             

            Check what logs says.

             

            Regards,

            Harish Saitwal

            1 of 1 people found this helpful
            • 3. Re: AR Email Messages Status Error
              Ganesh Gore

              do you see any error in below forms?

              AR System Email Error Logs

              AR System Email Error Messages

               

               

              • 4. Re: AR Email Messages Status Error
                Ricky R

                Hi Ganesh,

                 

                No records in both forms.

                 

                Regards,

                • 5. Re: AR Email Messages Status Error
                  Ricky R

                  Hi All,

                   

                  I got this error logs in the remedy ar email logs.

                   

                  <EML> <TID: 3050> <SEVERE > <LoggingModule> <MBConnection.java:486> /* Sen Jun 05 2017 23:53:36.023 */ Could not connect to :[Email Server Name]

                  <EML> <TID: 3050> <SEVERE > <LoggingModule> <MBConnection.java:487> /* Sen Jun 05 2017 23:53:36.023 */ No login methods supported!

                  <EML> <TID: 1978> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 05 2017 23:55:26.072 */ 550 5.7.1 Client does not have permissions to send as this sender

                  [ ]

                  <EML> <TID: 1976> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 05 2017 23:55:26.078 */ 550 5.7.1 Client does not have permissions to send as this sender

                  [ ]

                  <EML> <TID: 1978> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 05 2017 23:55:26.082 */ 550 5.7.1 Client does not have permissions to send as this sender

                  [ ]

                   

                  What does it mean?

                   

                  Regards,

                  • 6. Re: AR Email Messages Status Error
                    Ganesh Gore

                    It means user configured in Email mailbox configuration form does not have enough permissions or may be some parameters are not correct.

                    As per BMC KB : 000130422:

                    You need to set  Email address and Reply to Address parameters as well.  go to the "Advanced Configuration" tab on the AR System Email Mailbox Configuration Form for the outbound SMTP mailbox and specify a value for Email Address and Reply To Address.

                    • 7. Re: AR Email Messages Status Error
                      Ricky R

                      Hi Ganesh,

                       

                      The user in email mailbox configuration form does not have enough permissions, so do you mean i need to check the permission of the user in the mail server,right?

                       

                      On the advanced configuration tab, i already set the email address and reply to address field for the ar email mailbox configuration. Do i need to set the email address on the advanced configuration tab as same as the email of email server user on basic server tab or we can use different email address?Since my configuration now is the email address not the email of email server user.

                       

                      Regards,

                      • 9. Re: AR Email Messages Status Error
                        Ricky R

                        Hi All,

                         

                        I still can't go out from this issue.

                        Now i am using SMTP outbox with SSL port (465) :

                         

                        I got this error logs from aremail :

                        <EML> <TID: 54> <SEVERE > <LoggingModule> <MBConnection.java:486> /* Jum Jun 16 2017 15:02:54.729 */ Could not connect to :[Host name]

                        <EML> <TID: 54> <SEVERE > <LoggingModule> <MBConnection.java:487> /* Jum Jun 16 2017 15:02:54.729 */ No login methods supported!

                        <EML> <TID: 43> <SEVERE > <LoggingModule> <MBConnection.java:323> /* Jum Jun 16 2017 15:03:15.839 */ Couldn't connect to host, port: [Host name], 465; timeout -1

                        <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:323> /* Jum Jun 16 2017 15:03:15.839 */ Couldn't connect to host, port: [Host name].com, 465; timeout -1

                        <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:323> /* Jum Jun 16 2017 15:03:15.842 */ Couldn't connect to host, port: [Host name], 465; timeout -1

                        <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:323> /* Jum Jun 16 2017 15:03:15.843 */ Couldn't connect to host, port: [Host name], 465; timeout -1

                         

                        I already communicate with the email sys administrator, he already inserted the ip ar server into the exhange connector but nothing helped.

                        What is the issue come from? the ar remedy email engine or the email server engine? i can do ping command from the ar server to the email server but why the log said that couldn't connect to host?

                         

                        Please advice

                         

                        Regards,

                        • 10. Re: AR Email Messages Status Error
                          Ravindrakumar Rodge

                          Can you try once to configure AR System Mailbox configuration with below protocol and port.

                           

                          Protocol: SMTP

                          Port: 25

                          HostName: IPAddress/Exchange server name

                          UserName

                          Password

                          SSL: False

                           

                          Make sure the above changes are reflected in Centralised Configuration & in emaildaemon.properties.

                           

                          Ask your Exchange admin to set the authentication mechanism as basic and LoginType as plaintext at exchange level and check if that helps to resolve this problem.

                           

                          Regards,

                          Ravindrakumar

                          • 11. Re: AR Email Messages Status Error
                            Ricky R

                            Hi Ravindra,

                             

                            Thanks for the reply.

                             

                            I already set the mailbox configuration as your recommendation but i can't see any parameter in centralized configuration or emaildaemon.properties that's reflected with the mailbox configuration parameter. what is the name of com.bmc.arsys.emaildaemon. parameter in the centralized configuration or emaildaemon.properties you mean?or should i insert additional the parameter manually?

                             

                            After i set the mailbox configuration, i restarted the bmc remedy email engine service then i checked the logs, this what i got in the logs :

                             

                            <SEVERE > <LoggingModule> <MBConnection.java:487> /* Sab Jun 17 2017 09:22:58.295 */ No login methods supported!

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.332 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.333 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.333 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 43> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.333 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.333 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.336 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.336 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 43> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.337 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.338 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.344 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.344 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.346 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.347 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.348 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 43> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.348 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.354 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.355 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.356 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.357 */ No authentication mechanisms supported by both server and client

                            <EML> <TID: 42> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.358 */ Could not connect to SMTP host:[mail server Name], port: 25, response: 421

                            <EML> <TID: 41> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.358 */ Could not connect to SMTP host: [mail server name], port: 25, response: 421

                            <EML> <TID: 40> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sab Jun 17 2017 09:22:58.359 */ Could not connect to SMTP host: [mail server name], port: 25

                             

                            There are error logs no authentication mechanisms, Is this related with the authentication mechanism in the exchange server you mentioned before?

                            *Right now i still wait the confirmation from the exchange admin about what the authentication mechanism and login type being used now.

                            • 12. Re: AR Email Messages Status Error
                              Ravindrakumar Rodge

                              Yes Ricky. The login supported error those are getting reported are related to the Authentication mechanism set at Exchange Level.

                              Below is the required setting for AR Email Engine to work properly.

                               

                              Authentication Mechanism: Basic

                              LoginType: PlainText

                               

                              KnowledgeArticle - BMC

                               

                              Check with SMTP Details at exchange level.

                              https://technet.microsoft.com/en-us/library/ff849710(v=exchg.160).aspx

                               

                              Check at exchange  level specifically related to Receive Connector:

                              Receive connectors

                               

                              Regards,

                              Ravindrakumar

                              • 13. Re: AR Email Messages Status Error
                                Ricky R

                                Hi Ravindra,

                                 

                                I already got the answer from the exchange admin. This configuration what i got :

                                 

                                 

                                 

                                 

                                Is the configuration is already alright? well, as you can see in each tab i couldn't find login type field you mentioned before?

                                 

                                After i set the configuration like as above, i still got the error :

                                 

                                <SEVERE > <LoggingModule> <MBConnection.java:487> /* Sen Jun 19 2017 08:50:07.889 */ No login methods supported!

                                <EML> <TID: 43> <SEVERE > <LoggingModule> <MBConnection.java:331> /* Sen Jun 19 2017 08:50:08.026 */ No authentication mechanisms supported by both server and client

                                <EML> <TID: 42> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.034 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                <EML> <TID: 41> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.042 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                <EML> <TID: 40> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.042 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                <EML> <TID: 41> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.186 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                <EML> <TID: 43> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.364 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                <EML> <TID: 42> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 08:50:08.694 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                 

                                Maybe is there any configuration need to set in the exchange server?

                                • 14. Re: AR Email Messages Status Error
                                  Ricky R

                                  Hi Ravindra,

                                   

                                  Afterall the exchange admin just suggested me to use 587 port SMTP for the bmc remedy email engine not 25 or 465 (SSL).

                                   

                                  if i used the 587 port the result is some of the email can sent but most of it end with error status.

                                   

                                  The email.logs :

                                   

                                  <EML> <TID: 54> <SEVERE > <LoggingModule> <MBConnection.java:486> /* Sen Jun 19 2017 14:00:08.684 */ Could not connect to :[Mail server]

                                  <EML> <TID: 54> <SEVERE > <LoggingModule> <MBConnection.java:487> /* Sen Jun 19 2017 14:00:08.685 */ No login methods supported!

                                  <EML> <TID: 42> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 14:00:09.017 */ 550 5.7.1 Client does not have permissions to send as this sender[ ]<EML> <TID: 42> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 14:00:09.072 */ 550 5.7.1 Client does not have permissions to send as this sender [ ]

                                  <EML> <TID: 42> <SEVERE > <LoggingModule> <SenderModule.java:370> /* Sen Jun 19 2017 14:00:09.119 */ 550 5.7.1 Client does not have permissions to send as this sender

                                   

                                  What is weird from my opinion is why there are some email can be sent but the error logs show the above logs? if it's couldn't connect it should be all the email record end with error status, isn't it?

                                   

                                  If the error logs like above so the solution is related with you post before (Security in the exhange server)?

                                   

                                  Please advice.

                                   

                                  Regards,

                                  1 2 Previous Next