8 Replies Latest reply on Oct 10, 2018 3:53 PM by Daniel Hudsky

    Administrator operations are disabled on this server.

    Atul Matkar

      Trying to customize on some fields in AR form, but AR Dev studio is not allowing. This is pre-configure Single VM CLM by BMC

       

      Any clue how to over come this?

       

      26 Error

      Administrator operations are disabled on this server.

      The BMC Remedy AR System server is configured to disallow administrator operations. If the server is part of a group of servers sharing the same database, perform the server operations on the server in the group that allows administrator operations.

        • 1. Re: Administrator operations are disabled on this server.
          LJ LongWing

          Take a look in the Server Information console.  If the server believes itself to be in a server group, but this server hasn't been designated as the admin server in that group, you will get this, additionally, if it isn't in a server group, but admin operations have been disabled, you will receive this...either way you need to get the configuration correct and the error won't occur anymore

          • 2. Re: Administrator operations are disabled on this server.
            Gobind Sharma

            Login with the Admin user into ITSM >> Applications >> AR System Administration Console >> System >> General >> Server information

             

            Now go to the "Configuration" tab and look for the check-box with label "Disable Admin Operations". Uncheck the check-box and try to create objects in Developer Studio.

             

            Hope this helps

             

            Regards

            • 4. Re: Administrator operations are disabled on this server.
              Kobus Duminy

              Also go to advanced tab and ensure that you do not have a server group name entered.

              Check the values for the following in the ar.conf (ar.cfg), it should be F:

              • Multiple-ARsystem-Servers:
              • Server-Group-Member:

              If not you need to modify and restart AR service.

              • 5. Re: Administrator operations are disabled on this server.
                Gobind Sharma

                Since i can see from your screenshot that the 'Server Group Member' check box is unchecked, i believe your stand alone AR server is not part of any server group.  In a non-server group environment, selecting or deselecting one of these options from the Configuration tab in the Admin tool will add an entry to the ar.conf / ar.cfg file:

                Disable-Admin-Ops: T (or) F

                Disable-Escalations: T (or) F

                Disable-Archive: T (or) F

                 

                You just need to make the changes in ar.conf / ar.cfg file i.e. Disable-Escalations: F

                 

                1. Stop ARS
                2. Edit ar.conf and update parameter
                3. Disable-Admin-Operations :F
                4. Start ARS

                 

                Please let me know if the issue still persist.

                • 6. Re: Administrator operations are disabled on this server.
                  Daniel Hudsky

                  I have the same problem on my lab now. 1805 - Disable-Admin-Ops: F (false)

                  I deleted all the records from these forms:

                   

                  select * from servgrp_applic

                  select * from servgrp_board

                  select * from servgrp_config

                  select * from servgrp_ftslic

                  select * from servgrp_op_mstr << big mistake!

                  select * from servgrp_resources

                  select * from servgrp_userlic

                  select * from AR_System_Server_Group_Operati

                  select * from AR_System_Service_Failover_Ran

                  select * from AR_System_Service_Failover_Whi

                   

                  Now my feature list is missing from Operational Ranking form..

                  I need to get this fixed because I can't create anything in Dev studio atm.

                   

                  Fixed by importing data back into the table:

                   

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Administration','1','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Approval Server','-1','Approval-Server-Suspended','SG-Check-Config','Approval-CHK-CONFIG;Approval')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Archive','3','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Assignment Engine','-1','Assignment-Engine-Suspended','SG-Check-Config','AE-CHK-CONFIG;AE-CACHE;AE-ASSIGN') 

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Atrium Integration Engine','8','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Atrium Integrator','9','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Business Rules Engine','-1','Business-Rules-Engine-Suspended ','SG-Check-Config','BR-CHK-CONFIG;BR-BRIE')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('CMDB','-1','CMDB-Service-Suspended','SG-Check-Config','CMDB-CHK-CONFIG;CMDB')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Cognitive Training Service','11','NULL','NULL','Cognitive')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('DSO','5','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('E-Mail Engine','6','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Escalation','2','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Flashboards','7','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Full Text Index','4','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Reconciliation Engine','-1','Reconciliation-Engine-Suspended','SG-Check-Config','Reconciliation-CHK-CONFIG;Reconciliation')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('Service Failover','10','NULL','NULL','NULL')

                  INSERT INTO servgrp_op_mstr ([operation] ,[opNum] ,[configLabel] ,[configCommand] ,[categoryStrs]) VALUES ('SLM Collector','-1','SLM-Collector-Suspended','SG-Check-Config','SLM-CHK-CONFIG')

                   

                  Now Admin functions are back on! happy

                  Big thanks to the US AR Server support team for helping out.

                   

                  • 7. Re: Administrator operations are disabled on this server.
                    Vaibhav Wadekar

                    Please refer KA # 000159247. It is because of empty records in servgrp_op_mstr table.

                     

                    You shouldnt have deleted record from servgrp_op_mstr table.

                     

                    ~ Vaibhav

                    1 of 1 people found this helpful
                    • 8. Re: Administrator operations are disabled on this server.
                      Daniel Hudsky

                      OK. Thx Vaibhav. I was following a resolution that has apparently worked for another customer, but not for me