6 Replies Latest reply on Mar 6, 2014 4:55 AM by Gregory Rodrigues

    Issues with patch deployment

      Share:|

      When i am trying to deploy certain selected patches those are not getting installing on to the end points. In the log file i can able to see below

       

      "<Patch Bulletin="MS14-009" CurrentState="Missing" Reason="File version is less than expected. [C:\WINDOWS\MICROSOFT.NET\FRAMEWORK\V4.0.30319\ASPNET_WP.EXE 4.0.30319.1 &lt; 4.0.30319.2034]" id="MS14-009.Q2901110.NDP40-KB2901110-v2-x86.exe.720619868" type="Patch" vendorId="Q2901110"/>"

       

      similarly there are many patches are not getting installing. can anyone help me on this.

        • 1. Re: Issues with patch deployment

          There is not problem here ..basically what you are seeing is that Patch service identifies that patch as Missing... Check the "Action" of the patch in the patch group... it should be set to "Install".

          • 2. Re: Issues with patch deployment

            I have set the Action of the patch in the patch group to "Install" only.

             

            where as this particular patch is installing on other machine.

            • 3. Re: Issues with patch deployment

              Please attach the patch service logs from the endpoint that is not installing the patch

              • 4. Re: Issues with patch deployment

                The patches are failing to download because of a slow network... involve your network team

                 

                [25/Feb/2014:14:00:20 +0000] - info user1 41130 Download Status: Updating all subscribed bundles

                [25/Feb/2014:15:43:09 +0000] - warning user1 41131 Download Error\

                com.marimba.castanet.util.DetailedException[600/0: com.marimba.castanet.util.DetailedException[603/-1: Connection closed]]\

                    at com.marimba.castanet.tuner.Request.requestError(Request.java:516)\

                 

                 

                Please note: DO NOT paste the content of the logs in the thread use the Attachment option.. it makes the thread completely unreadable.

                • 5. Re: Re: Issues with patch deployment

                  Hi Gregory,

                   

                  Thanks for your response. i am having a few queries on this.

                   

                  1. Some Patches are not installing due to the machines are in Reboot Pending. Is there any way to find the machines which requires Reboot.
                  2. In some of the machines Tuner service has been stopped. How to find out the those machines.
                  3. While installing the patches users are getting popups to reboot the machine. Is there any option to suppress it.
                  4. On some of the machines Patch service is not updating regularly.
                  • 6. Re: Re: Issues with patch deployment

                    1. Some Patches are not installing due to the machines are in Reboot Pending. Is there any way to find the machines which requires Reboot.

                    There are canned query in RC will give you information on all machine and state if patch x:

                    /Query Library/Patch Management/Patch Reports/

                    Check which one suites your need.


                    2. In some of the machines Tuner service has been stopped. How to find out the those machines.

                    There is no easy way to tell which machines have the tuner service in a stopped state. You can use the canned report to identify the last scan time of the machines. That would give you a list of all machines that have not reported in x number of days. But this of course could be due to various reasons. (Machine shutdown, not on network, data insertion issues etc., ). I would do the following:

                    - Setup a pre-logon script to check if the tuner is installed.

                    - Set the scanner service to run on user logon. using the logon.notify & logon.action properties to force a scan manually

                     

                    3, While installing the patches users are getting popups to reboot the machine. Is there any option to suppress it.

                    Depends on how you are controlling the patch service reboots via Policy or Patch Service plugin or using CRS? Eitherway you would have the option to allow user to postpone the reboot. But typically all patching should happen off peak-hours, but still there would be machine that go offline as users shut them down etc., in those situations there is not much we can do unless you want to explore using WoW tasks for patching

                     

                    4. On some of the machines Patch service is not updating regularly.

                    There could be many reasons for this. Machines being shutdown, machines not reporting back data (Inventory issues) blackout schedules, product defect ., we need to look at them individually and categorize them as we go along. (Open a new thread if you need help once you have them sorted out in categories.)