1 2 Previous Next 20 Replies Latest reply on Jun 27, 2013 11:08 AM by Jesus Sandoval Branched to a new discussion.

    Not create AST form when create a CI

    Jesus Sandoval

      Hello everybody,

       

      I have the next issue, when I create a new CI throught Class Manager the CI is created also the forms but when I click "sync de UI" the AST forms not created then I click "update all" but has the same behavior. The next images show the problem.

       

       

       

       

       

       

      could help me please?

       

      Thanks and regards.

        • 1. Re: Not create AST form when create a CI
          Laurent Matheo

          There are quite some issues with SyncUI, did you check this thread for example?

          https://communities.bmc.com/message/260829#260829

          • 2. Re: Not create AST form when create a CI
            Gustavo del Gerbo

            Hi Jesus,

             

            You are in 7.6.04 right? What patch?

            Also, from above screenshot I can see the field "Tiene UI de activo" is set to NO.

            You need to set these to yes for each of your new classes.

            Then click on "Actualizar UI de Activo" for each one.

            • 3. Re: Not create AST form when create a CI
              Jesus Sandoval

              Hello Gustavo,

              Yes I am in the 7.6.04 patch 2 and within the tests that I did, I set the field "Tiene UI de activo" to YES but the result has the same problem.

               

              Next is the extract of the log "CMDBSynchronizeUI.log":

               

              - This is the first test when I created the CI and SynchronizeUI:

               

              PRUEBA_QTZ

              [2013/05/23 12:10:52.2229] [ TRACE ] [TID: 0000000011]  : Instantiating Application object

              [2013/05/23 12:10:52.2397] [DETAILS] [TID: 0000000011]  : +ARGetListEntryWithFields [SHR:SchemaNames]

              [2013/05/23 12:10:52.3609] [WARNING] [TID: 0000000011]  : [72]    The query matched more than the maximum number of entries specified by the server

              [2013/05/23 12:10:52.3611] [DETAILS] [TID: 0000000011]  : -ARGetListEntryWithFields    OK

              [2013/05/23 12:10:52.3661] [DETAILS] [TID: 0000000011]  : +ARGetListSchema

              [2013/05/23 12:10:52.7356] [DETAILS] [TID: 0000000011]  : -ARGetListSchema    OK

              [2013/05/23 12:10:52.7530] [ TRACE ] [TID: 0000000011]  : Calling Application update

              [2013/05/23 12:10:52.7532] [ TRACE ] [TID: 0000000011]  : Processing Class: BMC.CORE:QTZ_Lab

              [2013/05/23 12:10:52.7533] [WARNING] [TID: 0000000011]  : No entry for Class: BMC.CORE:QTZ_LAB found on Form: SHR:SchemaNames

              [2013/05/23 12:10:52.7534] [WARNING] [TID: 0000000011]  :     Check that Field: 230000009 on SHR:SchemaNames has the Class GUID for Class: BMC.CORE:QTZ_Lab

              [2013/05/23 12:10:52.7535] [ TRACE ] [TID: 0000000011]  : Processing Class: BMC.CORE:PRUEBA_QTZ

              [2013/05/23 12:10:52.7536] [WARNING] [TID: 0000000011]  : No entry for Class: BMC.CORE:PRUEBA_QTZ found on Form: SHR:SchemaNames

              [2013/05/23 12:10:52.7537] [WARNING] [TID: 0000000011]  :     Check that Field: 230000009 on SHR:SchemaNames has the Class GUID for Class:

               

              BMC.CORE:PRUEBA_QTZ

              [2013/05/23 12:10:52.7538] [ INFO  ] [TID: 0000000011]  : Application UI synchronization completed

              [2013/05/29 16:58:19.1028] [ INFO  ] [TID: 0000000002]  : Application UI synchronization started - command string: -f SHR:SchemaNames -g 230000000 -c

               

              230000009 -C BMC.CORE:PRUEBA_QTZ -R -D

               

               

               

              In the second test this was the result:

               

               

              PRUEBA_QTZ

              [2013/05/29 16:58:24.5803] [ TRACE ] [TID: 0000000002]  : Classes impacted by the change to BMC.CORE:PRUEBA_QTZ:

              [2013/05/29 16:58:24.5805] [ TRACE ] [TID: 0000000002]  :     BMC.CORE:PRUEBA_QTZ

              [2013/05/29 16:58:24.5807] [ TRACE ] [TID: 0000000002]  : Instantiating Application object

              [2013/05/29 16:58:24.6332] [DETAILS] [TID: 0000000002]  : +ARGetListEntryWithFields [SHR:SchemaNames]

              [2013/05/29 16:58:24.7330] [DETAILS] [TID: 0000000002]  : -ARGetListEntryWithFields    OK

              [2013/05/29 16:58:24.7416] [DETAILS] [TID: 0000000002]  : +ARGetListSchema

              [2013/05/29 16:58:25.2040] [DETAILS] [TID: 0000000002]  : -ARGetListSchema    OK

              [2013/05/29 16:58:25.2443] [ TRACE ] [TID: 0000000002]  : Calling Application update

              [2013/05/29 16:58:25.2445] [ TRACE ] [TID: 0000000002]  : Processing Class: BMC.CORE:PRUEBA_QTZ

              [2013/05/29 16:58:25.2447] [ TRACE ] [TID: 0000000002]  : Found entry in configData Map

              [2013/05/29 16:58:25.2448] [ TRACE ] [TID: 0000000002]  : Entry in configData Map was good

              [2013/05/29 16:58:25.2450] [ TRACE ] [TID: 0000000002]  :     (Reqiured) Target Form:    AST:PRUEBA_QTZ

              [2013/05/29 16:58:25.2451] [ TRACE ] [TID: 0000000002]  :     (Optional) Primary Join:   

              [2013/05/29 16:58:25.2453] [ TRACE ] [TID: 0000000002]  :     (Optional) Secondary Join:   

              [2013/05/29 16:58:25.2454] [ TRACE ] [TID: 0000000002]  : Start processing of form: AST:PRUEBA_QTZ

              [2013/05/29 16:58:25.2456] [ TRACE ] [TID: 0000000002]  : Creating new form

              [2013/05/29 16:58:25.2457] [ TRACE ] [TID: 0000000002]  : Will fetch display info for form AST:QTZ_Lab

              [2013/05/29 16:58:25.2459] [ TRACE ] [TID: 0000000002]  : Will make the new Form AST:PRUEBA_QTZ that is an inner join on BMC.CORE:PRUEBA_QTZ

              [2013/05/29 16:58:25.2539] [ ERROR ] [TID: 0000000002]  : Failed to create Form for: AST:PRUEBA_QTZ

              [2013/05/29 16:58:25.2541] [ ERROR ] [TID: 0000000002]  :     Form does not exist on server

              [2013/05/29 16:58:25.2543] [ ERROR ] [TID: 0000000002]  :     AST:QTZ_Lab

              [2013/05/29 16:58:25.2544] [ TRACE ] [TID: 0000000002]  : Errors encountered while processing form: AST:PRUEBA_QTZ

              [2013/05/29 16:58:25.2546] [ INFO  ] [TID: 0000000002]  : Application UI synchronization com

               

              Can you help me with the interpretation??

              • 4. Re: Not create AST form when create a CI
                Vignesh Nadar

                Hi Jesus,

                 

                We see the below Error in the CMDBSyncUI.log

                "No entry for Class: BMC.CORE:PRUEBA_QTZ found on Form: SHR:SchemaNames"

                 

                The above error occurs, if the Number of Records in "SHR:SchemaNames" form is more than the Max Get List Entry Value defined in the Server Information -> Configuration Tab.

                 

                Increase the Max Get List Entry Value to something greater than the total number of records in the "SHR:SchemaNames" and rerun the "Sync UI" to resolve this issue.

                 

                Thanks,

                Vignesh

                • 5. Re: Not create AST form when create a CI

                  I can see the below pasted warning...

                   

                  [2013/05/23 12:10:52.7533] [WARNING] [TID: 0000000011]  : No entry for Class: BMC.CORE:QTZ_LAB found on Form: SHR:SchemaNames

                   

                  Which says that the form "BMC.CORE:QTZ_LAB" is not added to SHR:SchemaNames mapping form.

                   

                  May be you can try adding the entry of the said form and try syncUI again. That should generate the AST forms for you.

                   

                  Thanks,
                  Mouneel

                  • 6. Re: Not create AST form when create a CI
                    Gustavo del Gerbo

                    Hi Jesús,

                     

                    In SP2 version we have no support in SyncUI if you have a limit set in the Remedy side.

                    Like Laurenth says:

                    Go to "AR System Administration Console->System->General->Server Information->Configuration->MaxEntries Return by GetList"

                    Put 0 there (unlimited).


                    That will resolve your problem.

                    Also, delete the AST:Form before running SYNCUI a second time, because now you already have a corrupted form.

                    • 7. Re: Not create AST form when create a CI
                      Gustavo del Gerbo

                      Vignesh,

                       

                      Like I post above, you have the same problem as Jesus. You need to remove the limitation for Max Get List Entry Value.

                       

                      This defect is fixed in 7.6.04SP5 to be released soon.

                      • 8. Re: Not create AST form when create a CI
                        Vignesh Nadar

                        Hi Gutavo,

                         

                        Yeah! thats right. Infact I have provided the Suggestion to the User. You can see i have asked the uses to set the max get list entry value greater then the total number of records in the SHR:SchemaNames form.

                        • 9. Re: Not create AST form when create a CI
                          Jesus Sandoval

                          Hi Laurent / Vignesh

                           

                          If I follow your recommendation don't affect the performance of the environment?

                           

                          (Laurent sorry but I guess that erased your comment for error)

                          • 10. Re: Not create AST form when create a CI
                            Vignesh Nadar

                            Jesus,

                             

                            Can you open the SHR:SchemaNames Form explicitly and do a 1=1 search? And see how many records are there?

                            So, say for example you see 6000 records, then set the Max Get List Entry to 6500 and your issue should be resolved.

                             

                            So, no need to set the Max Get List to Unlimited here. Also, once the Sync UI is completed then you can change the MAx List entry to Original Small value as per your requirement.

                             

                            -Vignesh

                            • 11. Re: Not create AST form when create a CI
                              Laurent Matheo

                              Jesús Sandoval wrote:

                               

                              Hi Laurent / Vignesh

                               

                              If I follow your recommendation don't affect the performance of the environment?

                               

                              (Laurent sorry but I guess that erased your comment for error)

                              I didn't erase my comment, someone branched it... (splitted it from main discussion)...

                              You just need to change the value when you do the Sync UI. When it's done, put back the previous value. It's a workaround

                               

                               

                              I don't know why my comment was branched... lol it's here now:

                              https://communities.bmc.com/thread/84976

                               

                              I see this:

                              [2013/05/23 12:10:52.3609] [WARNING] [TID: 0000000011]  : [72]    The query matched more than the maximum number of entries specified by the server

                              Try to change the "getlist" parameter in server information to unlimited:

                              Login with an administrator account.

                              Go to "AR System Administration Console->System->General->Server Information->Configuration->MaxEntries Return by GetList"

                              Put 0 there (unlimited).


                              Try again.

                              • 12. Re: Not create AST form when create a CI
                                Jesus Sandoval

                                Hello all,

                                I follow your recommendation but i have the same issue ... this is the new log:

                                 

                                [2013/06/14 11:54:23.5408] [ TRACE ] [TID: 0000000002]  :     PRUEBA_QTZ

                                [2013/06/14 11:54:24.0750] [ TRACE ] [TID: 0000000002]  : Classes impacted by the change to BMC.CORE:PRUEBA_QTZ:

                                [2013/06/14 11:54:24.0752] [ TRACE ] [TID: 0000000002]  :     BMC.CORE:PRUEBA_QTZ

                                [2013/06/14 11:54:24.0754] [ TRACE ] [TID: 0000000002]  : Instantiating Application object

                                [2013/06/14 11:54:24.1418] [DETAILS] [TID: 0000000002]  : +ARGetListEntryWithFields [SHR:SchemaNames]

                                [2013/06/14 11:54:24.2645] [DETAILS] [TID: 0000000002]  : -ARGetListEntryWithFields    OK

                                [2013/06/14 11:54:24.2731] [DETAILS] [TID: 0000000002]  : +ARGetListSchema

                                [2013/06/14 11:54:24.6236] [DETAILS] [TID: 0000000002]  : -ARGetListSchema    OK

                                [2013/06/14 11:54:24.6449] [ TRACE ] [TID: 0000000002]  : Calling Application update

                                [2013/06/14 11:54:24.6451] [ TRACE ] [TID: 0000000002]  : Processing Class: BMC.CORE:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6452] [ TRACE ] [TID: 0000000002]  : Found entry in configData Map

                                [2013/06/14 11:54:24.6453] [ TRACE ] [TID: 0000000002]  : Entry in configData Map was good

                                [2013/06/14 11:54:24.6454] [ TRACE ] [TID: 0000000002]  :     (Reqiured) Target Form:    AST:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6455] [ TRACE ] [TID: 0000000002]  :     (Optional) Primary Join:   

                                [2013/06/14 11:54:24.6456] [ TRACE ] [TID: 0000000002]  :     (Optional) Secondary Join:   

                                [2013/06/14 11:54:24.6457] [ TRACE ] [TID: 0000000002]  : Start processing of form: AST:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6458] [ TRACE ] [TID: 0000000002]  : Creating new form

                                [2013/06/14 11:54:24.6459] [ TRACE ] [TID: 0000000002]  : Will fetch display info for form AST:QTZ_Lab

                                [2013/06/14 11:54:24.6460] [ TRACE ] [TID: 0000000002]  : Will make the new Form AST:PRUEBA_QTZ that is an inner join on BMC.CORE:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6520] [ ERROR ] [TID: 0000000002]  : Failed to create Form for: AST:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6521] [ ERROR ] [TID: 0000000002]  :     Form does not exist on server

                                [2013/06/14 11:54:24.6522] [ ERROR ] [TID: 0000000002]  :     AST:QTZ_Lab

                                [2013/06/14 11:54:24.6523] [ TRACE ] [TID: 0000000002]  : Errors encountered while processing form: AST:PRUEBA_QTZ

                                [2013/06/14 11:54:24.6525] [ INFO  ] [TID: 0000000002]  : Application UI synchronization completed

                                • 13. Re: Not create AST form when create a CI
                                  Gustavo del Gerbo

                                  Hi Jesus,

                                   

                                  Looks like your AST form depends on a higher level form:

                                  [2013/06/14 11:54:24.6521] [ ERROR ] [TID: 0000000002]  :     Form does not exist on server

                                  [2013/06/14 11:54:24.6522] [ ERROR ] [TID: 0000000002]  :     AST:QTZ_Lab

                                   

                                  Have you run Sync UI on QTZ_Lab? This one seems to be a parent of this one.

                                  • 14. Re: Not create AST form when create a CI
                                    Jesus Sandoval

                                    Hi Gustavo,

                                    No I didn't run Sync UI on QTZ lab... I need to Synchronize the 2 forms AT:QTZ Lab and AST:PRUEBA:QTZ ??... But I need also doing a change o modification in the CI to will be reflect in the Sync??

                                    1 2 Previous Next