1 2 Previous Next 24 Replies Latest reply: Aug 16, 2012 3:31 PM by pega RSS

Help

pega

So we have installed Discovery and need to configure to scan.  I'm testing this in dev first and there're windows, unix linux vm etc.

I tried to test scan and ran fine but no good result.  So is this credential issue?  what are the configurations I need to make?

skipped  50 (saying unsupported device)

no access 60 (saying used heristics)

no response 70

 

Thanks,

Alex

  • 1. Re: Help
    Chris Hughes

    Hi Alex -

     

    I would suggest running through some of our community training:

     

    http://discovery.bmc.com/confluence/display/ADDMcet/Community+Enablement+Tutorials

     

    No access is generally a credential issue.

     

    Regards,

     

    Chris

  • 2. Re: Help
    ckandu

    Skipped (unsupported device) means that ADDM appliance has No access to the target system, the credential has not even tried.  Can you ping from your ADDM appliance to your target system?

  • 3. Re: Help
    pega

    Ok.  I'll try to ping skipped ones.  By the way, I'm trying to install Windows Proxy and reading getting started PDF.

    It says Windows proxies are downloaded as install files on page 16 but which install file?  Is this ADDM install files?

    because ADDM install is for Linux so where's this "install files from the applicance and installed onto the local Windows host"?  I don't see Windows Proxy install file in EPD.

  • 4. Re: Help
    Zoe Stone

    Hi Alex,

     

    Try looking here for answers on Windows Proxy installation.

     

    and you might want to look here to begin to understand the different discovery states.

     

    I also invite you have a look at our online documentation, which allows you to do a keyword searches.

  • 5. Re: Help
    Chris Hughes

    Alex wrote:

     

    I don't see Windows Proxy install file in EPD.

    The proxies need to be downloaded from the appliance.  From discovery its under tools.

  • 6. Re: Help
    pega

    Chris,

     

    I spoke too soon... I found it and installed it.  I'll try to use credential (AD) and report back to you.

  • 7. Re: Help
    pega

    Oh, by the way, after install, it tried to connect to discovery but the URL seems different.

    The main page is http://ip-address/ui but this one showed http://ip-address/ui/slave something.

    And I wasn't able to login with system login account.  Is that use different login and do you have URL (after close I can't remember the page)

  • 8. Re: Help
    ckandu

    You will need to login to your ADDM appliance and get its ip information (run ifconfig command as root).

  • 9. Re: Help
    ckandu

    Once you get the ip address, you can login using http://ip_address

  • 10. Re: Help
    pega

    I got the ip address and can login but from proxy server, it showed http://ipaddress/ui/slave*** and i can't remember that url and what's the significance of that url

  • 11. Re: Help
    pega

    Okay, I got the proxy server installed and trying to use Active Directory credential.  I used my domain account to set up until service acct gets set up for the testing.  So ADDM use system for login and active directory proxy server use alex.  But when I ran scan, I still don't have any success

    not sure what changed but before proxt set up;

    skipped         50

    no access     60

    no response  70

    after proxy set up;

    skipped          39

    no access      71

    no response   70

    Is the set up or configuration not done correctly?  I followed getting started with BMC atrium discovery.

  • 12. Re: Help
    Andrew Waters

    We need to break this down into steps otherwise we are just guessing at what you have configured.

     

    Starting with Linux.

     

    You need to have a credential set up on the host credentials page (see here).

     

    Once that it is place, try selecting Test from the Actions options on the right of the credential and providing an IP address for one of the Linux machines. This will take you to the Credential Test page. Presumably it will fail, in which case click through the Failure link to see what the system attempt to do. This should give you some indication of what is failing.

     

    For Windows.

     

    Setting up a windows proxy is slightly more complicated. Presuming you have ADDM 8.3.x, you will need to create a Windows Proxy Pool and define the slave within the pool (see here). If you are using an Active Directory (AD) Proxy there is no need to add a Windows credential - it will use the account the same account as the running Proxy. On the other hand if you are using a Credential Proxy you will need to add credential with the windows method. Again try testing this and see what happens.

     

    If we could see what you are getting from the tests then we may be able to help you more.

  • 13. Re: Help
    pega

    Thanks Andrew.

    I just installed ADDM 8.3.2 and installed Windows Proxy and slave pool was added long with proxy server install.

    Upon install, I ran credential test with an ip address and it failed.  saying ssh, rlogin, and telent failed and stopped.  I'm using AD proxy.

    we have mostly windows and some unix, vmware.

     

    Alex

  • 14. Re: Help
    Andrew Waters

    If checking for Windows access you will either need to select test from the Windows proxy Test action or selecting "Test IP Access..." on the Credentials Tests tab otherwise the system will not try to use an AD proxy to access the machine.

1 2 Previous Next