1 2 Previous Next 17 Replies Latest reply: Jul 6, 2012 5:40 AM by Nitin Murkute RSS

    VGP Job Failed

    Nitin Murkute

      Hi All,

       

       

      I am trying to do RHEL5.6 Provisioning through VGP.It gets successfully created the VM from that VGP template in VC server.

      But it gets automatically poweroff and deleting that VM from VC Server after creating the VM.And Deploying VGP Job shows me the error about the failing of the job.

       

       

      Please find the attached log file for RSCD agent  of VC Server.

       

      Regards,

      Nitin

        • 1. VGP Job Failed
          Bhumika NameToUpdate

          Can you please provide us CO-Server logs?

          • 2. Re: VGP Job Failed
            Nitin Murkute

            Hi bhanmant,

             

            Can you please elaborate more what you are asking for ?

             

            Thanks & Regards,

            Nitin

            • 3. VGP Job Failed
              Bhumika NameToUpdate

              On machine where you have distributed your CO & installed agent, you will find logs generated in agent install directory (typically : C:\Program Files\BMC Software\BladeLogic\RSCD) with file name similar to 'blcoserver_BMC_VMware_VirtualInfrastructureManager_win646836-Administrator.log'

               

              Can you please provide us all these log files?

               

              Also on machine where you have installed appserver you will find appserver.log in <appserver install directory> (typically : C:\Program Files\BMC Software\Bladelogic\NSH) \br. Can you please provide us that as well?

              • 4. Re: VGP Job Failed
                Nitin Murkute

                Hi bhanmant,

                 

                Please find attached log files for blcoserver_BMC_VMware_VirtualInfrastructureManager_win642796-BLAdmin.log

                and appserver.log

                 

                Thanks & Regards,

                Nitin

                • 5. VGP Job Failed
                  Bhumika NameToUpdate

                  I see following errors in co-server logs :

                   

                  url:  host:  user:

                  DAAL VMware_PLUGIN - VMwareActionHandler::getDetails - stdout: VMWARE_WEB_SERVICE_CONNECTION_FAILED

                  Failed to establish connection either because of invalid web service details or web service is down. Check logs for further details.

                   

                  Can you please confirm that you have provided correct url, user & password in Connection PSI of VC & that you are able to live browse VC properly?

                  • 6. Re: VGP Job Failed
                    Geeta Gokhale

                    Hi Nitin,

                     

                    you have attached vmware log. you need to attach similar log for RHEV.

                    the name will be something like blcoserver_BMC_RHEV*.log

                     

                    please attach the log again.

                     

                    Geeta

                    • 7. Re: VGP Job Failed
                      Geeta Gokhale

                      Hi,

                       

                      Please ignore my comment. please check your credentials.

                      • 8. Re: VGP Job Failed
                        afzal shaikh

                        Just a thought .... If your credentails are fine, try using the IP instead of hostname in the connection url string.

                        • 9. Re: VGP Job Failed
                          Bhumika NameToUpdate

                          I am little confused here.. if the connection details are missing / incorrect VGJ should fail at inial step itself. But in your case it deploys a VM, then rollbacks it.

                          I hope you have provided correct blcoserver_*.log to us.

                           

                          Also can you please provide us bldeploy log? you can find it in "<agent install directory>(C:\Program Files\BMC Software\BladeLogic\RSCD)\Transactions\log\" with name similar to bldeploy-bb978e4ccb0a3224867824d61fc583c1.log

                          • 10. Re: VGP Job Failed
                            Bill Robinson

                            does the version of the agent in the VM template match the appserver ?

                            • 11. Re: VGP Job Failed
                              Nitin Murkute

                              Hi All,

                               

                              My Agent version is same as that of APP Server.

                              Also,I have checked the Credantial for all i.e. Connection_User,Connection_Password,Connection_URL and if there is problem with the credantial then it fails in the initial stage of the VGP as bhanmant said.

                              Also,I tested for IP Addredd insted of taking Hostname in Connection String.


                              But still facing the same issue.

                               

                              Regards,

                              Nitin

                              • 12. Re: VGP Job Failed
                                Umar Shaikh

                                Can you please execute the job once more and once you get the failure, send over the following log files:

                                1. C:\Program Files\BMC Software\BladeLogic\RSCD\blcoserver_BMC_VMware_VirtualInfrastructureManager_*-BLAdmin.log
                                2. C:\Program Files\BMC Software\BladeLogic\RSCD\blcoserver_BMC_VMware_VirtualInfrastructureManager_*-BladelogicRSCD.log

                                 

                                Also, please let us know the following:

                                1. vCenter version
                                2. ESX Host version
                                3. Guest OS with version (You've mentioned it's Red Hat 5.6)
                                4. Are VMware Tools installed into the template?
                                • 13. VGP Job Failed
                                  Nitin Murkute

                                  Hi All,

                                   

                                  Thanks for all of you for valuable support.

                                  I got the cause of my problem.

                                  The VGP Job failed because I am using the customized OS option in VGP Creation.

                                  But when I created the new VGP without customizing anything in VGP Template,it gets successfully created the VM in VC Center and also Power on the VM and not deleting the VM as well.

                                   

                                  VGPO.jpg

                                   

                                  But I want to know about Why I am not able to customised the VM Template while creating the VGP.

                                   

                                   

                                   

                                  Thanks & Regards,

                                  Nitin

                                  • 14. VGP Job Failed
                                    Umar Shaikh

                                    Please let us know the following:

                                    1. vCenter version
                                    2. ESX Host version
                                    3. Guest OS with version (You've mentioned it's Red Hat 5.6)
                                    4. Are VMware Tools installed into the template?

                                     

                                    I guess 5.6 OS customization support is present in vSphere 5 onwards. Could you please answer the questions above to enable us to help you?

                                    1 2 Previous Next