1 2 Previous Next 17 Replies Latest reply: Jul 30, 2012 9:36 AM by Jason W RSS

Missing Datasets in Atrium

Jason W

Some datasets in Atrium have disappeared. I can still successfully import data into the datasets but they are not visible in Explorer-find, the Reconciliation or Atrium Engines. I haven't knowingly updated any permissions for said datasets but am confised as to why I can't see them any more.

 

Does anyone  have any ideas?

  • 1. Re: Missing Datasets in Atrium
    Abhijit Valvekar

    It may be cache problem, please check by refreshing cache.

     

    Thanks and Regards,

    Abhijit Valvekar

  • 2. Re: Missing Datasets in Atrium
    Jason W

    Hi Abhijit Valvekar,

     

    Sadly I have tried that one and it doesn't work.

     

    Thanks

     

    Jason

  • 3. Re: Missing Datasets in Atrium
    Mauro Ciuti

    Hi Jason,

     

    What do you mean exactly by “some” Datasets? Is any of the Out-of-the-Box Datasets missing?

     

    Did you try using a user account with Administrator priviliges AND a fixed license?

     

    After doing an import, do the CI appear in the corresponding BMC.CORE form?

     

    Regards,

     

    Mauro

  • 4. Re: Missing Datasets in Atrium
    Jason W

    The data sets that have evaporated are ones that I have added manually, a couple of months ago.

     

    Tried the Admin bit and this made no difference.

     

    Don't seem to be having any trouble reconciling the invisible data sets into the Live BMC Asset

  • 5. Missing Datasets in Atrium
    Laurent Matheo

    If you open form "BMC.CORE:BMC_BaseElement", do you see them in the dataset drop list?

  • 6. Missing Datasets in Atrium
    Jason W

    My confusion grows!!!

     

    No the dataset isn't present within the BMC_BaseElement drop down.

     

    I did initially think that the dataset had been deleted but when I tried to re-create the dataset label Remedy gave me an error saying that the dataset already exists.

  • 7. Re: Missing Datasets in Atrium
    Mauro Ciuti

    I would check that the Datasets are present in the Datasets form.

     

    If the Datasets are not there, means someone removed them or a DB backup was restored, but adding them might do the trick.

     

    You might still be able to run imports and reconciliation because everything is already configured and the Dataset name is just a field in the database table where the CIs are stored but since Atrium/ARS/ITSM don’t have this datasets “declared” in the Datasets form, you can’t see them in Atrium Explorer, Recon Engine, etc.

     

    Hope this helps.

     

    Regards,

     

    Mauro

  • 8. Re: Missing Datasets in Atrium
    Jason W

    OK thanks, makes sense but could you possibly elaborate a little on what you mean by the dataset form?

  • 9. Missing Datasets in Atrium
    Laurent Matheo

    Did you add some permissions on the datasets?

     

    bmc.core.config:bmc_dataset

  • 10. Re: Missing Datasets in Atrium
    Mauro Ciuti

    When you save the CI, it saves it to a table in the DB. The Dataset field you see it in a form is only a field used to separate the CIs in groups of data, but everything ends up in the same table for a given CI.

     

    You can run a SQL log and create a new CI in any dataset. You should be able to see in which table it’s inserted, or you can SELECT FROM ARSCHEMA WHERE name LIKE %CI_CLASS% (i.e. % BMC_ComputerSystem%)

     

    Regards,

     

    Mauro

  • 11. Re: Missing Datasets in Atrium
    Jason W

    Thanks again for your engagement Mauro.

     

    It does seem that those two datasets have gone and are not available throught the dataset form.

     

    Am I simply in a position now where I will have to create a new dataset with a new name and then update my CI mappings, data exchanges etc?

  • 12. Re: Missing Datasets in Atrium
    Mauro Ciuti

    Hi Jason,

     

    If this is a Test system, you can try creating the Dataset as if it where a new one, but choosing the same name you used before.

     

    Then go to the CI form and create a new CI. If you’re able to select the dataset you created in that form, and then you’re able to reconcile it, you’re probably fine.

     

    Regards,

     

    Mauro

  • 13. Re: Missing Datasets in Atrium
    Jason W

    Mauro

     

    Fortunately it is a test system but when I try and use the same dataset name I get an error instructing me that the dataset name already exists. Not to worry I'll simply stick a number on the end.

     

    Thanks again for your assistance

  • 14. Missing Datasets in Atrium
    Devendra Yadav

    Please Check Row Level security for your datasets user form bmc.core.config:bmc_dataset

1 2 Previous Next