1 2 Previous Next 15 Replies Latest reply: Jul 13, 2012 5:23 AM by Sachin Dhale RSS

Compliance content.

Sachin Dhale

I have installed the compliance content on our appserver, and I am able to discover the templates on Windows and Linux servers, however when i try to discover on Solaris boxes even though the job shows success component has no information when i live browse it. It works fine with Linux and windows boxes though. Pl advise

 

BL Verision :8:00

  • 1. Compliance content.
    Niranjay Bharati

    Try running any of the EO for solaris template manually from appserver . Is it the OOB component template that you are using ?

  • 2. Compliance content.
    Sachin Dhale

    Thanks for the reply, my other extended objects works fine which are manually created on app servers, not sure what OOB Component template means, I am using the templates which are installed through BMC Compliance content.

  • 3. Compliance content.
    Sachin Dhale

    Can anyone help me out with this?

  • 4. Compliance content.
    Jayendra Saxena

    Hi Sachin, i trust you have installed compliance content with all OS libraries as well. Well are you able to see the Solaris servers components in Discovery Job results ?? , if no check the Solaris boxes agent status and version.

     

     

    --Jay

     

  • 5. Compliance content.
    Sachin Dhale

    Yes, I installed on for all OS libraries, I can see the component in desovery job results, with no information at all, and also i have tried on solaris8,9,10 with the respective component per OS, but no success, Server shows the extended object created from the template, however when i live browse the component its blank and compliance job wont run because of this.  It works fine on windows and linux though.

  • 6. Re: Compliance content.
    Bill Robinson

    Is there anything in the agent log when you try the live browse in the gui ?

  • 7. Compliance content.
    Sachin Dhale

    No activity is showing in RSCD Logs at all, Appserver log are as below

     

    30 Jun 2012 10:16:50,484] [Select-Client-Connections-Thread] [DEBUG] [::] [] -----Activity on control socket!

    [30 Jun 2012 10:16:50,484] [Client-Connections-Thread-1] [DEBUG] [::] [] Adding session for thread : Client-Connections-Thread-1

    [30 Jun 2012 10:16:54,250] [Scheduled-Job-Tasks-Thread-4] [DEBUG] [System:System:] [Schedule Monitor] Adding session for thread : Scheduled-Job-Tasks-Thread-4

    [30 Jun 2012 10:16:54,250] [Scheduled-Job-Tasks-Thread-4] [DEBUG] [System:System:] [Schedule Monitor] Removing session for thread : Scheduled-Job-Tasks-Thread-4

    [30 Jun 2012 10:16:54,312] [Scheduled-System-Tasks-Thread-6] [DEBUG] [System:System:] [App Server Heartbeat] Adding session for thread : Scheduled-System-Tasks-Thread-6

    [30 Jun 2012 10:16:54,312] [Scheduled-System-Tasks-Thread-6] [DEBUG] [System:System:] [Update Job Run Counts] Removing session for thread : Scheduled-System-Tasks-Thread-6

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [::] [] Removing session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Adding session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Removing session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Adding session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Provider processed method: com.bladelogic.model.provision.ProvisionDeviceService_getAllProvDevicesBeingProvisioned()

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Removing session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:54,531] [Select-Client-Connections-Thread] [DEBUG] [::] [] -----Activity on control socket!

    [30 Jun 2012 10:16:54,531] [Client-Connections-Thread-3] [DEBUG] [::] [] Adding session for thread : Client-Connections-Thread-3

    [30 Jun 2012 10:16:55,484] [Client-Connections-Thread-2] [DEBUG] [::] [] Removing session for thread : Client-Connections-Thread-2

    [30 Jun 2012 10:16:55,484] [Client-Connections-Thread-2] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Adding session for thread : Client-Connections-Thread-2

    [30 Jun 2012 10:16:55,484] [Client-Connections-Thread-2] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Removing session for thread : Client-Connections-Thread-2

    [30 Jun 2012 10:16:55,484] [Client-Connections-Thread-2] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Adding session for thread : Client-Connections-Thread-2

    [30 Jun 2012 10:16:55,484] [Client-Connections-Thread-2] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Provider processed method: com.bladelogic.model.job.jobrun.JobRunService_getAllJobRunProgress()

    [30 Jun 2012 10:16:55,515] [Client-Connections-Thread-2] [DEBUG] [BLAdmin:BLAdmins:10.8.62.97] [Client] Removing session for thread : Client-Connections-Thread-2

    [30 Jun 2012 10:16:55,515] [Select-Client-Connections-Thread] [DEBUG] [::] [] -----Activity on control socket!

    [30 Jun 2012 10:16:55,515] [Client-Connections-Thread-2] [DEBUG] [::] [] Adding session for thread :

  • 8. Compliance content.
    ajay_uke

    Hi Sachin,

     

    Can you pl let me know, which compliance template are you facing this problem for[i.e is it SOX,PCI,DISA etc?]

    Pl execute the below command from NSH[specially interested in Security and  User permissions]

    agentinfo <name/ip of the solaris target>

     

    Regards,

     

    Ajay

  • 9. Compliance content.
    Sachin Dhale

    HI Ajay,

     

    its for all the templates SOX,PCI,DISA.

     

    I dont think servers have permission issue, below is the output

     

    Agent Release   : 8.0.7.722

    Hostname        : Test

    Operating System: SunOS 5.10

    User Permissions: 0/0 (root/root)

    Security        : Protocol=5, Encryption=TLS1

    Host ID         : 849DE578

    # of Processors : 32

    License Status  : Licensed for NSH/CM

  • 10. Compliance content.
    Bill Robinson

    so you see the component, but there are no objects under it?

     

    what role are you running discovery with?  and what role do you try and live browse with?

  • 11. Compliance content.
    Sachin Dhale

    Thats correct Bill, no object under the component, I am using BLAdmin role for discovery as well as Live Browse.

  • 12. Compliance content.
    ajay_uke

    Hi Sachin,

     

    Can you pl try below steps and provide details

    1. Click on the Solaris targets listed under Servers and check the "OS_release" under properties
    2. Also could you attach the Discovery job run result logs?[If you click on the template it shall have discovery condition as ??TARGET.OS?? equals Solaris AND ??TARGET.OS_RELEASE?? is one of ("5.8","5.9","5.10"]
    3. Through NSH command prompt from Appserver check cd //<target name/ip> , ls , df -h

     

    Regards,

     

    Ajay

  • 13. Compliance content.
    Manojkumar Kadam

    Hi Sachin,

     

    Can you please enable the debug log for the agent and rerun the test for both Linux and Solaris targets. It would be interesting to know exactly what is happening at the agent.

     

    ~Manoj

  • 14. Compliance content.
    Bill Robinson

    Ok, i think i know what your issue is...  the solaris templates do not have browse enabled for any of the objects, but the linux ones do.  this is normal.  actually the linux ones should not have anything enabled for browse, but i recall an old issue so try this:

     

    open the linux template

    check browse under general and save the template

    look in the browse tab and remove the objects listed there

    save the template

    uncheck browse in the general area and save the template

     

    then your linux templates should show nothing.

     

    if you want to be able to browse, then edit the template, check 'browse' in the general tab and choose the parts you want to show up in browse and save the template.

     

    there is no requirement to have parts to browse for the compliance jobs to function properly w/ these templates.

1 2 Previous Next