2 Replies Latest reply on Jun 7, 2012 8:32 AM by Rahul Priyadarshy

    AIE Jobs- Not Setting - Mark AS Deleted Field.

    Rahul Priyadarshy

      Hi All,


      We have a job running succesfully to fetch computer System CI data into CMDB ,SCCM (custom data set) data set.Everything is working fine except this delete flag.


      In Data exchange - we have set the option DELETE ACCORDING TO DATA MAPPING OPTION


      In CI Class Mapping ->

                                    Main Tab->we have selected MARK AS DELETED Option

                                    Delete Field Mapping Tab- there is a mapping which sets Mark As Deleted attribute =1


      Do we need to do something extra apart from this to acheive this.


      Do we are required to do the field mapping for this "Mark as Delete" attribute with SCCM feed as we hava a field in SCCM which tells us the status as Active/Inactive?



      Rahul P

        • 1. AIE Jobs- Not Setting - Mark AS Deleted Field.
          Carey Walker

          Hi Rahul


          The Delete processing is intended to recognise when a record in the target dataset is not present in the source dataset, and take some action on the target record (usually setting the MarkAsDelete flag, as you are doing). So if, say, a discovery solution finds CIs A,B,C on day, and these are imported correctly, then the next time it only finds A,B the Delete option will set the MarkAsDelete flag in the target dataset for CI C since it seems like it no longer exists.


          So if EVERY CI in your SCCM dataset exists in the target dataset, there is no Delete action required/performed. I think this is what you are seeing.


          If you want to set the MarkAsDelete attribute when the SSCM data tells you you have an Inactive status, then you need to have an explicit mapping in the main data mapping section that sets MarkAsDelete to Yes only when the SCCM statsu flag says Inactive.


          Hope that helps.

          • 2. AIE Jobs- Not Setting - Mark AS Deleted Field.
            Rahul Priyadarshy

            thanks a lot for your prompt response and explanation.