11 Replies Latest reply: Jun 5, 2012 12:11 AM by Emran NameToUpdate RSS

    Issue with Webservice publish and consume

    Emran NameToUpdate

      Hi All,

       

      We have issue in consuming & publishing  web services in our production environment.

       

      Below is my environment,

       

      OS:  HP-UX B.11.31

      Hardware : ia64

      Server Version : 7.6.04 Build 002 201101141059

      Database : Oracle

      Database Version: 11.2.0.1.0 - 64bit Production

      Midtier: 7.6.04 SP3 Hotfix 043012

      Apache: Apache Tomcat/6.0.20

      Java: 1.5.0.19

       

      Web Service WSDL:

       

      <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:urn="urn:Test_WS_PRD">

         <soapenv:Header>

            <urn:AuthenticationInfo>

               <urn:userName>imran</urn:userName>

               <urn:password>XXXXX</urn:password>

               <!--Optional:-->

               <urn:authentication>?</urn:authentication>

               <!--Optional:-->

               <urn:locale>?</urn:locale>

               <!--Optional:-->

               <urn:timeZone>?</urn:timeZone>

            </urn:AuthenticationInfo>

         </soapenv:Header>

         <soapenv:Body>

            <urn:Create>

               <urn:Submitter>Imran</urn:Submitter>

               <!--Optional:-->

               <urn:Assigned_To>Imran</urn:Assigned_To>

               <urn:Status>1</urn:Status>

               <urn:Slice_Token></urn:Slice_Token>

               <!--Optional:-->

               <urn:User_Name>csscorp_ws</urn:User_Name>

               <!--Optional:-->

               <urn:Password>csscorp_ws</urn:Password>

               <!--Optional:-->

               <urn:Response_Format>XML</urn:Response_Format>

               <!--Optional:-->

               <urn:Description>Testing</urn:Description>

               <!--Optional:-->

               <urn:requester>Junaid</urn:requester>

            </urn:Create>

         </soapenv:Body>

      </soapenv:Envelope>

       

      Web Service Publish : I published the above webservice from remedy and tried consuming it from SOAP UI,  and received the below response back from remedy

       

      <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

         <soapenv:Body>

            <soapenv:Fault>

               <faultcode>soapenv:Server.userException</faultcode>

               <faultstring>ERROR (9130): Message not in catalog; Message number = 9130; ; nested exception is:

      java.lang.RuntimeException: No support for attachments</faultstring>

               <detail>

                  <ns1:hostname xmlns:ns1="sdp3s.waltham.infracentre.comhttp://xml.apache.org/axis/">sdp3s.waltham.infracentre.com</ns1:hostname>

               </detail>

            </soapenv:Fault>

         </soapenv:Body>

      </soapenv:Envelope>

       

      Web Service Consume: I consumed an external webservice provided by 3rd party application and tried consuming through filter,  and then also i got the same error.

      WS_error.JPG

       

      Please help me here to fix this issue.

       

      Thanks & regards,

      Imran