1 Reply Latest reply on May 25, 2012 12:23 PM by David Pinkowitz

    Moving footprints from default web server on Windows 2008 R2

      I am attempting to move the Footprints website out from under the default website on IIS 7.5 on Windows 2008 R2. I was able to do this under IIS 6 on Windows 2003. I am getting CgiModule execute errors when trying to handle perl. Has anyone been able to do this successfully and what steps did you have to take?


      Thank you,



        • 1. Re: Moving footprints from default web server on Windows 2008 R2
          David Pinkowitz

          You can configure IIS on your new website using the same functionality that FootPrints uses during a new installation. When run from the command line, it is menu driven and relatively simple to follow. Let us know if this solves your problem.


          Here are the steps:


          1. Open the Command Prompt by right clicking and running as Administrator (you will know you did this correctly if "Administrator" appears in the title bar of the Command Prompt as in the picture below). Change to the cgi directory of your FootPrints Service Core installation and execute MRConfigIIS.pl using the Perl interpreter:


          2. Create a new web site (please note that if you are making the new web site on the same port as the old web site they cannot both run simultaneously, so the new one may not start when you are complete unless you stop the one on the default web site)


          3. Enter the path to your FootPrints installation.


          4. Give the web site a name (this is arbitrary and more for your own use)


          5. Configure your port number


          6. Determine whether to enable dynamic compression (on Windows 2008 Server and above, this is recommended as the server will ensure that compression is disabled when CPU usage is high)


          7. You are done and the new web site will be displayed after pressing Enter.


          8. At this point, you may be done, but if it still does not work, there could be a permissions problem due to changes in the default permissions for IIS. If so, when you exit MRConfigIIS.pl, you will also need to run MRchangePermissions.pl also from the cgi directory.



          Message was edited by: David Pinkowitz on 5/25/2012. Updated instructions to include how to correctly open the Command Prompt and how to change permissions if necessary.