1 2 Previous Next 15 Replies Latest reply: Mar 23, 2012 8:50 AM by Jacek Stasieluk RSS

AtriumCore 7.6.04 SP2 Installation

Jacek Stasieluk

Hi everyone,

 

I've got another enormous problem with AtriumCore SP2 installation. Please help me or check my configuration.

Symptoms are following (see image below). Installator stops in this screen and do nothing. In arreror.log are this entries:

 

Thu Feb 23 15:25:19 2012 : Action Request System(R) Server x64 Version 7.6.04 SP2 201110080614

(c) Copyright 1991-2011 BMC Software, Inc.

Thu Feb 23 15:25:47 2012  390600 : Could not find or read the optional license tags file. (ARNOTE 452)

Thu Feb 23 15:25:47 2012     C:\Program Files\Common Files\AR System\Licenses\GRemArsProd\arsystem.tag

Thu Feb 23 15:35:56 2012  390600 : Cannot establish a network connection to the AR System Plug-In server (ARERR 8760)

Thu Feb 23 15:35:56 2012     ARSYS.ARDBC.ARREPORTENGINE  ARSYS.ARDBC.REGISTRY : RPC: Name to address translation failed - No such hostname

Thu Feb 23 15:35:57 2012  390600 : Cannot establish a network connection to the AR System Plug-In server (ARERR 8760)

Thu Feb 23 15:35:57 2012     GRemArsProd (9555) BMC.FILTERAPI.NORM.ENGINE : RPC: Miscellaneous tli error - System error (Connection refused)

Thu Feb 23 15:35:58 2012  390600 : Cannot establish a network connection to the AR System Plug-In server (ARERR 8760)

Thu Feb 23 15:35:58 2012     GRemArsProd (9556) AIS.FILTERAPI : RPC: Miscellaneous tli error - System error (Connection refused)

Thu Feb 23 15:40:05 2012  AssignEng : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:41:06 2012  Dispatch : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:43:05 2012  AssignEng : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:44:05 2012  Dispatch : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:46:05 2012  AssignEng : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:47:05 2012  Dispatch : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93

Thu Feb 23 15:48:05 2012  AssignEng : Timeout during data retrieval due to busy server -- retry the operation (GRemArsProd.gemini.kbsa)  ARERR - 93...

.

....etc.

 

In logs of database (Oracle 11G 11.2.0.1) installed on Red Hat Enterprise 5.5 (Tikanga).

 

I've installed AtriumCore on Windows Server 2008 x64 with Java 1.6.0.29 x64 and Oracle Client x64.

 

We have changed default Oracle port number from 1521 to 1531. I don't know if it's change something.

 

Has anyone got any idea about it?

 

Regards,

  • 1. Re: AtriumCore 7.6.04 SP2 Installation
    Dhananjay Gundre

    Can you provide contents of ar.cfg file?

  • 2. Re: AtriumCore 7.6.04 SP2 Installation
    Ganesh Gore

    1. Have you added Atrium Core App license ?

    2. Have you changed server name alias/plugin server/port. Also provide plug server config file contents.

     

    -@GG

  • 3. AtriumCore 7.6.04 SP2 Installation
    Laurent Matheo

    Perhaps you have an issue with your server names in fact... Something like (in your plugin alias in ar.cfg):

    servername

    servername.domainName

    and one of them isn't solved by your DNS to your server?

     

    I know a collegue failed installing the CMDB because of that. Can you also post the installer logs from AtriumCore?

  • 4. AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Hello,

     

    Thanks for Your answer. Here i present my ar.cfg. I broke this installation and in this conf file there are some entries from AtriumCore.

     

    dhananjay - it's for You

    Server-Name: GRemArsProd

    Server-directory: D:\BMC Remedy\ARSystem\ARServer\Db

    Multiple-ARSystem-Servers: T

    Register-With-Portmapper: T

    TCD-Specific-Port: 0

    Plugin-Port:

    Alternate-Approval-Reg: T

    Currency-Ratio-Client-Refresh-Interval: 60

    Homepage-Form: AR System Customizable Home Page

    Locale-List: en

    Required-Field-Identifier: *

    Required-Field-Identifier-Location: 1

    Plugin: ardbcconf.dll

    Plugin: reportplugin.dll

    Plugin: ServerAdmin.dll

    Plugin: FlashboardObject.dll

    Db-name: ARSYS

    Db-user: aradmin

    Oracle-Clob-Storage-In-Row: T

    Db-Character-Set: UTF-8

    Oracle-Two-Task: REMEDYPR

    Db-password: W0YwrOhhVWmgZif9zw7CCXOE+rpvStorO488rK76DRsaZWSFxOwAGzSiNmVhz12BhYcHi4yDhenBBnorT0yECIAcQg1xTucf99YJPpvU9O+2r1IdrVSd9g==

    DSO-User-Password: LZjvcwgENif92aedmyDxC8ghG7aJDEuEPG5e16exAafpvCJshFXcERn7ESpkkAwLuggEbHYEFa13wAqd8IFC3J3bkPSoKKG4fKviVdgKVd42IOiBuG3PkQ==

    Remedy-App-Service-Password: hZsu/wIUKzyERxw2UBToDzoZvjoBNVsOkZpfvj+/06dFrg3eEkJnnRRhS7IrS68FyxEvvq8C2vZ2Co395kBdvVpPprt96sq3lEI939j+isz9Xkan4LFkBQ==

    Mid-Tier-Service-Password: ilHKWdUTeUt4kP+nbv9Tm2u9Ev8a6zY5KjV/fFfivKBiorWwmawhMplXk6oYy6E7iFEZODKW5jV8DtBCQycwNfZnx6F7xrmZZhnUsfGb0xHGuosAEkiIkQ==

    Plugin: "D:\BMC Remedy\ARSystem\arealdap\arealdap.dll"

    Plugin: "D:\BMC Remedy\ARSystem\ardbcldap\ardbcldap.dll"

    Full-Text-Configuration-Directory: D:\BMC Remedy\ARSystem\ftsconfiguration\conf

    Full-Text-Collection-Directory: D:\BMC Remedy\ARSystem\ftsconfiguration\collection

    Plugin: "D:\BMC Remedy\ARSystem\approval\bin\arapprove.dll"

    Application-Enable: T

    Approval-RPC-Socket: 390680

    AE-Log: OFF

    AE-Trace: OFF

    Oracle-Cursor-Sharing: FORCE

    Set-Process-Timeout: 60

    Submitter-Mode: 1

    Cache-Mode: 1

    Next-ID-Block-Size: 100

    Log-Form-Selected: 0

    Allow-Guest-Users: F

    Default-Web-Path: http://gremmidprod01/arsys

    Private-RPC-Socket:  390601   1   1

    Private-RPC-Socket:  390603   1   1

    Private-RPC-Socket:  390620  24  30

    Private-RPC-Socket:  390635  30  30

    Private-RPC-Socket:  390680   2   2

    System-Messages-Displayed: 1

    Filter-Api-Timeout: 180

    Load-Shared-Library-Path: D:\BMC Remedy\AtriumCore\cmdb\server64\bin

    Plugin-Loopback-RPC-Socket: 390626

    Plugin-Path: D:\BMC Remedy\ARSystem

    Plugin-Path: D:\BMC Remedy\ARSystem\pluginsvr

    Plugin-Path: D:\BMC Remedy\ARSystem\arealdap

    Plugin-Path: D:\BMC Remedy\ARSystem\ardbcldap

    Plugin-Path: D:\BMC Remedy\AtriumCore\cmdb\server64\bin

    Load-Shared-Library: cmdbsvr7604_win64.dll

    CMDB-Inline-Normalization: T

    CMDB-Install-Directory: D:\BMC Remedy\AtriumCore\cmdb

    RE-Log-File-Location: D:\BMC Remedy\AtriumCore\Logs

    Server-Plugin-Alias: ARSYS.ARF.REGISTRY ARSYS.ARF.REGISTRY GRemArsProd.gemini.kbsa:9999

    Server-Plugin-Alias: ARSYS.ARDBC.REGISTRY ARSYS.ARD;ARSYS.ARDBC.ARREPORTENGINE ARSYS.ARDBC.ARREPORTENGINE

    Server-Plugin-Alias: GRemArsProd.gemini.kbsa:9999;ARSYS.ARF.QUERYPARSER ARSYS.ARF.QUERYPARSER GRemArsProd.gemini.kbsa:9999

    Server-Plugin-Alias: ARSYS.ALRT.WEBSERVICE ARSYS.ALRT.WEBSERVICE GRemArsProd.gemini.kbsa:9999

    Server-Plugin-Alias: ARSYS.ARF.WEBSERVICE ARSYS.ARF.WEBSERVICE GRemArsProd.gemini.kbsa:9999

    Server-Plugin-Alias: ARSYS.ARF.FTS ARSYS.ARF.FTS GRemArsProd.gemini.kbsa:9998

    Server-Plugin-Alias: BMC.FILTERAPI.NORM.ENGINE BMC.FILTERAPI.NORM.ENGINE GRemArsProd:9555

    Server-Plugin-Alias: AIS.FILTERAPI AIS.FILTERAPI GRemArsProd:9556

    Server-Plugin-Alias: BMC.ARDBC.ATRIUM.API BMC.ARDBC.ATRIUM.API GRemArsProd:9556

    Server-Plugin-Alias: DSM.FILTER DSM.FILTER GRemArsProd:9556

    Server-Plugin-Alias: BMC.ARDBC.DEPRECATION.PLUGIN BMC.ARDBC.DEPRECATION.PLUGIN GRemArsProd:9556

    Server-Plugin-Alias: BMC.FILTERAPI.NOE BMC.FILTERAPI.NOE GRemArsProd:9556

    Server-Plugin-Alias: BMC.ARDBC.ATRIUM.NGIE BMC.ARDBC.ATRIUM.NGIE GRemArsProd:9556

    Server-Plugin-Alias: BMC.FILTERAPI.EVENT_ENGINE BMC.FILTERAPI.EVENT_ENGINE GRemArsProd:9556

     

    Ganesh - Your questions

    1. Have you added Atrium Core App license ? - YES, i don't know if You know, that SP2 installer  has alone add this license , but i  add it manually before.

    2. Have you changed server name alias/plugin server/port. Also provide plug server config file contents - NO, i didn't change  anything.

     

    Laurent Mateo - You sugestions:

    Maybe this is it. As You can see in ar.cfg there no information about servername with domain. I almost sure that this names are resolved in my DNS server.

    Tommorow i will send You post installation ActirumCore logs.

  • 5. AtriumCore 7.6.04 SP2 Installation
    Laurent Matheo

    Actually for the Server-Plugin-alias I see some with domain and some without

    Server-Plugin-Alias: BMC.FILTERAPI.EVENT_ENGINE BMC.FILTERAPI.EVENT_ENGINE GRemArsProd:9556

    Server-Plugin-Alias: ARSYS.ALRT.WEBSERVICE ARSYS.ALRT.WEBSERVICE GRemArsProd.gemini.kbsa:9999

     

    There is something weird with your pluginsvr_config.xml too, it seems some keyword haven't been changed (for example):

    <port>$FEDERATION_PORT$</port>

    <filename>$BMC_CMDB_PLUGINSVR_PATH$/ais/ais.jar</filename>

            <pathelement type="path">$BMC_NE_PLUGIN_PATH$/</pathelement>

                      <pathelement type="path">$BMC_CMDB_PLUGINSVR_PATH$/ais/</pathelement>

                      <pathelement type="location">$BMC_CMDB_PLUGINSVR_PATH$/ais/imapi.jar</pathelement>

                      <pathelement type="location">$BMC_CMDB_PLUGINSVR_PATH$/ais/imcomm.jar</pathelement>

                      <pathelement type="location">$BMC_CMDB_PLUGINSVR_PATH$/atrium.jar</pathelement>

     

    But perhaps it's because installation didn't finish properly.

     

    Your email engine doesn't seem to be working ok:

    ERROR (90): Message not in catalog; Message number = 90; ONC/RPC program not registered GRemArsProd

     

    You got weird errors in your arerror.log:

    Fri Feb 24 14:19:34 2012     GRemArsProd   : RPC: Program not registered

    Fri Feb 24 14:19:36 2012  390600 : Cannot establish a network connection to the AR System Plug-In server (ARERR 8760)

    Fri Feb 24 14:19:36 2012     GRemArsProd (9998) ARSYS.ARF.FTS : RPC: Miscellaneous tli error - System error (Connection refused)

     

    In the ar.cfg from your zip file I see 3 different server-names...

    Server-Name: GRemArsProd

    Server-Name: gremarsprod.gemini.kbsa

    Server-Name: gremarsprod

     

     

    Do your server boot without any error at all (even without CMDB)?

  • 6. AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Laurent,

     

    This entrance below are fill automaticaly by installer. I think in this bins to SP2 there are some mistakes, but i've made many Remedy install and this is not a problem.

    Server-Plugin-Alias: BMC.FILTERAPI.EVENT_ENGINE BMC.FILTERAPI.EVENT_ENGINEGRemArsProd:9556

    Server-Plugin-Alias: ARSYS.ALRT.WEBSERVICE ARSYS.ALRT.WEBSERVICEGRemArsProd.gemini.kbsa:9999

     

    Installer stops in 70-80% i think. I deducate it from the time. Normally installation time (AtriumCore) is 70-80 min, this screen comes from 50 min.

     

    I know, that there are some weird entrance in arerror.log, but why and what is it? . Server names I've added, cause this is 3 or 4 installation and it's failed. I though, that maybe this help.

     

    My server boot normally after ARS installation. Without any problems, errors etc. Tommoror / or today i will make an installation with net traicing, maybe there are some problem.

     

    Thanks for Your help, maybe You we will find resolution together...but we have to still looking for

     

    Regards,

  • 7. Re: AtriumCore 7.6.04 SP2 Installation
    Ganesh Gore

    I was expecting same! (See second question in my previous post). I would suggest you first do changes in ar.cfg and pluginsvr_config.xml files.use unique server name (GRemArsProd.gemini.kbsa). clear arerror.log and restart server. recheck again if any error in arerror/armonitor log files. Clear temp files & run installer again.

    bdw, I know installer adds license auto.but personally I recommend to add it manually.

    just thought It would help you!!!

     

     

     

    -@GG

  • 8. AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Hello,

     

    I've attached atriumcore_install_log.txt file with logs writing during an installation. Please check it.

    Ganesh - i cannot re-run installer once more, because there is an error that installer is still running or installation was failed (no matter if i clear temp folder and use clear/unninstall atriumcore from atrium-maintanance-tool).

    Like i wrote before - i've added this license manually.

     

    Regards,

    Jack

  • 9. AtriumCore 7.6.04 SP2 Installation
    martincrothall

    Jack,

     

    You need to remove the entry in SHARE:Application_Properties form - you should find an entry for BMC Atrium CMDB where 'Property Name' = "State" and 'Property Value' = "Failed" or "Running". Change the 'Property Value' to "Success" and you should be able to run the installer again.

     

    Hope that helps,

     

    Martin

  • 10. AtriumCore 7.6.04 SP2 Installation
    Laurent Matheo

    Do you have any logs in folder "D:\BMC Remedy\AtriumCore\Logs\"? It's weird that it stops on this one:

     

    I wonder if this cmdbdriver made some logs...

    LOG EVENT {Description=[Command array "C:\Users\SWSREM~1\AppData\Local\Temp\Utilities\cmdb\cmdbdriver.exe" -s GRemArsProd -u Demo -p <not_displayed> -t 0 -x "D:\BMC Remedy\AtriumCore\cmdb\en\workflow\syncabstractviews.drm"]}

     

    Or in folder (check for *.log):

    "C:\Users\SWSREM~1\AppData\Local\Temp\Utilities\"

  • 11. Re: AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Laurent,

     

    Of course, that i have logs in folder <atrium_path>\logs. This entry, that You wrote i executed from command line. You can see the results in attachment (update my oryginal post).

     

    In folder Utilities also i've got a files.

     

    Laurent. I don't know why, but before i've attached *.jpg file with Utilities folder.

     

    Regards,

  • 12. AtriumCore 7.6.04 SP2 Installation
    Laurent Matheo

    Ok cool that there are some logs Can we have them?

    Are there some logs with filename "*_error.log"?

    can you check if you got some logs in the "utilities" and sub-folders?

     

    So the command line failed (ARERR 93), it does the same error if you restart your armonitor service?

  • 13. Re: AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Laurent,

     

    There are no _error.log files in Utilities folder and sub-folders

     

    This ARERR 93 - i don't know if it the same error, when i restart armonitor service. I have to go to our Customer place and check it.

     

    Please notice, that Oracle version is 11g 2R 11.2.0.3.0 - i don't know if it's good way to find a resolution, but maybe?

     

    Regards,

  • 14. Re: AtriumCore 7.6.04 SP2 Installation
    Jacek Stasieluk

    Hello again,

     

    I've got some news about my problem. I've found plugin_server configuration with wrong entries. Could someone review this files please?pluginsrv_config.JPG

     

    This file becomes when my installation stopped. This file is here:

    D:\Program Files\BMC Software\AtriumCore\cmdb\plugins\ne - normalization engin - like in errror logs.

     

    Best Regards,

    Jack

1 2 Previous Next