9 Replies Latest reply: Jun 16, 2011 12:46 PM by Mike Lee RSS

    Move INVDB 6.0.3.0

    Mike Lee

      Good Morning,

       

      I'm using a really old version of Marimba (6.0.3.0). I need to move the database from one server to another.  I've been looking around in the console on how to re-attach the database to a new server.  Is it as simple as going into System Settings > Data Source > Database and creating a new "link"?

       

      I didn't know if there was anyting else I should worry about by doing this.

       

      Thank you for anyone that can assist me.  It would be greatly appreciated.

        • 1. Move INVDB 6.0.3.0
          Adil Rathore

          Yes you need to simply set up the inventory connection and reporting connections using the inventory and user_view respectively from the Data Source > Database page...

           

          However, before that you need to confirm whether database users have been migrated as well and the user permissions are intact on the invdb database.

          • 2. Move INVDB 6.0.3.0
            Mike Lee

            Great.  Thank you so much!!  I'll make sure we check that as well.  I greatly appreciate your time.

            • 3. Move INVDB 6.0.3.0
              Mike Lee

              Sorry, one last question.  If for some reason the database is corrupted and unable to restore.  How would I go about creating a new DB?  Within the same screen if I point it to a DB and its empty will it build the schema?  Was curious.

               

              Thanks so much.

              • 4. Move INVDB 6.0.3.0
                Jake Morgan

                If that is the case then all you would do is create the database, log into the BBCA Schema Manager, point it to your created db and install the core, patch, etc schmea via the schema manager.

                • 5. Move INVDB 6.0.3.0
                  Mike Lee

                  I had to start from scratch.  So, I have the schema rebuilt, etc and the tables are showing up in SQL, which is great.... so I got that far

                   

                  However, now when going to report center and choosing my database to use, it fails.  I look at the sql logs and it says I have a bad password for user_view.  I'm able to go into system settings and connect with user_view, etc..so I'm not sure whats going on.  Is there another spot that I need to input the user_view password?  Maybe I need to update it somehwere else so it will attach.

                   

                  Thanks all!

                  • 6. Move INVDB 6.0.3.0
                    Jake Morgan

                    There are two types of connections: Inventory and Reporting. Make sure you have set the user_view password in both.

                    • 7. Move INVDB 6.0.3.0
                      Mike Lee

                      Ya, I'm doing something wrong I knew it. Ha.  Unfortunatly, I don't see where to enter these connections.  So sorry, can you let me know where to go to enter it in for both?

                       

                      Thanks again!

                      • 8. Move INVDB 6.0.3.0
                        Adil Rathore

                        In BBCA Console you need to go to Applications > System Settings > Data Source > Database.

                         

                        Here you can provide the Inventory and Reporting connections

                        • 9. Move INVDB 6.0.3.0
                          Mike Lee

                          Wow. How did I miss that.  Geez.  Sorry guys.  Ya, I'm in now.


                          I greatly appreciate your paitence and help.  This is great!