DWP Catalog: 3.4 Upgrade: STATEMENT_AR_APPLICATION_VERSION_MISMATCH

Version 1
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    MyIT Service Broker



    PROBLEM:

    We are upgrading from DWP 3.4 Catalog 3.3.02 to 3.4 but the upgrade fails with the following error:

    SEVERE,com.bmc.install.product.arsuitekit.tasks.ARSuiteKitConnectionInformationValidationTask,
     LOG EVENT {Description=[[SEVERE]STATEMENT_AR_APPLICATION_VERSION_MISMATCH[String:BMC Remedy Action Request System,String:9.5.00,String:>=,String:9.5.00.002]],Detail=[Invalid BMC Remedy Action Request System version. Detected BMC Remedy Action Request System version is 9.5.00. BMC Remedy Action Request System version should be >= 9.5.00.002.]}

     


    SOLUTION:

    This problem only affects upgrades from 3.3.00 GA > 3.3.0.01 > 3.3.02 > 3.4 and is caused by an incorrect value for the "BMC Remedy Action Request System" property in the "SHARE:Application_Properties" form. To correct please do the following:

    1) Open form “SHARE:Application_Properties” using the Mid Tier
    2) Search the entries in form with qualification 'Property Value' = "9.5.00" AND 'Property Name' = "Version"
    3) Modify all searched entries and set the 'Property Value' = “9.5.00.002” for searched entries
    4) Save the modification.
     


    Article Number:

    000141826


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles