MyIT Integration with RSSO not working

Version 24
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    MyIT Digital Workplace


    APPLIES TO:

    3.3.02



    PROBLEM:

    MyIT Version: 3.3.02
    RSSO: 9.1.02

    We have performed manual integration of MyIT with RSSO however the integration is not working.
    Same RSSO works fine with Remedy.


     


    SOLUTION:

    The following files are available in Remedy SSO installer at the location—Disk1/files/rsso-agent/:

        rsso-agent-all.jar
        rsso-agent.properties
        rsso-sdk-atsso.jar
        rsso-client-impl.jar
        sso-sdk.properties

    1.) Make sure you have below files present in  <CATALINA_BASE>/external-conf/lib folder, these file can be copied from above RSSO location if it does not exists
    rsso-agent-all.jar file
    rsso-sdk-atsso.jar
    rsso-client-impl.jar

    2.) Make sure you have below files present in  <CATALINA_BASE>/external-conf/ folder,  these file can be copied from above RSSO location if it does not exists
    rsso-agent.properties file
    sso-sdk.properties

    3.) Check if the rsso-agent.properties is modified correctly as below,
    The value of 'agent-id' property in the rsso-agent.properties file must be a unique identifier, and must be same on all nodes in SmartIT/BMC Digital Workplace cluster. It is recommended to set its value to a simple identifier instead of a HTTP URL. For example,

    agent-id=myit_smartit_agent.
    logout-urls=/atssologout.html

    4.) Check if in Smart IT database table 'SmartIT_System.TENANT', the value of column 'SAML_AUTHENTICATION' is True when the database is Microsoft SQL, and 1 when the database is Oracle.

    5.) If all in place restart MyIt Tomcat for the integration to work.

    6.) If any above file is missing it will land into 404 Error and in tomcat trace logs you can see Null Pointer error exceptions.

    7.) Once above files are in place and correct and you no longer see 404 error however when you launch the myit URL and see error like,
    An error has occured please contact your administrator.
    Please capture ux DEBUG logs as below,

    -add  to '${CATALINA_HOME}\external-conf\logback.xml' additional configuration from file 'add_to_logback.xml' (could be found below attached) to enable logs for 'com.bmc.rsso.*' classes.
     
    -add 'log4j.rsso-webagent.properties' file (could be found from below attached) to '${CATALINA_HOME}\external-conf\' folder and replace '${catalina.home}' for property 'log4j.appender.FILE.File=' by valid path to MyIT Tomcat directory  (e.g. 'log4j.appender.FILE.File=/opt/Apache Software Foundation/Tomcat 8.0/logs/rsso-webagent.log')

    -Restart MyIT server with RSSO integration, collect and send us logs from '/Smart_IT_MyIT/Logs' and 'Tomcat/logs' folders after several attempts to access MyIT application
     
    8.) In above logs if you notice error like below,
    http-nio-9000-exec-2           | RID: 2 | ERROR   | c.b.rsso.sdk.impl.SSOServiceImpl | Error retrieving SSO configuration
    java.net.MalformedURLException: no protocol: =http://server:8080/rsso/checkconfig?client-id=myit_smartit_agent

    This means that character '=' somehow was appended to URL while parsing property *sso-external-url* from file 'rsso-agent.properties'.
    Probably there is some issues with file parsing process or properties file could be corrupted.

    -In such scenarios you can replace rsso-agent properties file from a clean RSSO system or used attached file and verify if integration works fine.













     


    Article Number:

    000138820


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles