Upgrade CMDB from 9.0 to 9.1 failed

Version 2
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    BMC Atrium Core - CMDB


    COMPONENT:

    BMC Atrium Core



    PROBLEM:

    Customer was  trying to upgrade to Dev environment from 9.0 to 9.1. When he tried to upgrade CMDB on the secondary server it failed and gave him the error below. 

    LOG EVENT {Description=[CMDB engine is not initialized. Please contact BMC Support after zipping all logs through Atrium Core Manitenance tool],Detail=[CMDB engine is not initialized.]} 


    SOLUTION:

    Open arerror.log and check if CMDB server Starting and Started

    Mon Jun 05 16:49:13.172 2017 Extension loaded: com.bmc.cmdb 9.1.00.SNAPSHOT bmc.cmdb.cmdbEngine
    Mon Jun 05 16:49:13.186 2017 CMDB Server Starting
    Mon Jun 05 16:49:33.749 2017 CMDB Server Started.

    If you cannot find lines at arerror.log, CMDB engine is not loaded.

    Below are the steps for CMDB accelerated method CMDB 9.1 upgrade failed with error CMDB initialization failed: 

    >>cmdb-9.1.00-SNAPSHOT copy this file to the location \...\BMC Software\ARSystem\deploy 

    >> open cmdb driver and run the below commands: 
    init 
    log 
    ssp 
    glc 
    after running glc command check if it loads all the classes 

    >>after server restart check cmdb_eng_debug_log at location \.....\BMC Software\ARSystem\Arserver\Db should show successful initialization of CMDB

    >> Delete the failed entry for Atrium CMDB from SHARE:Application_Properties form. 


    Article Number:

    000135616


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles