401 URL monitoring error while performing Web URL monitoring of websites hosted on IIS

Version 1
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    ProactiveNet Performance Management Suite


    APPLIES TO:

    BMC ProactiveNet Performance Management Suite



    PROBLEM:

     

    401 URL monitoring error while performing Web URL monitoring of websites hosted on IIS

     


    SOLUTION:

     

    Legacy ID:KA349498

      

    The Web URL monitor is deprecated. This monitor can be used as a replacement:
    https://docs.bmc.com/docs/display/public/wsm9/Home?key=wsm9


    In the meantime, check the automatic log-in settings in IE. 

    The BPPM URL monitoring does not use IE proxy settings. When testing a URL, it is not recommended to use IE to validate if a URL is reachable or not as it will not provide the correct information.

    If using BPPM 8.5, use the ProactiveNet Agent's httpmon diagnostic utility to test the URL.
    ==========
    1) From the screen shot IE is configured to "Automatically detect settings" (WPAD) which can cause it to find and use a proxy server which does not need authentication when coming from IE
    1a) Web Proxy Autodiscovery Protocol (http://en.wikipedia.org/wiki/Web_Proxy_Autodiscovery_Protocol)
    1b) About implementing WPAD (http://technet.microsoft.com/en-us/library/cc995261.aspx)

    2) The ProactiveNet Agent has an httpmon diagnostic utility
    \Program Files\ProactiveNet\Agent\pronto\bin\httpmon.bat
    2a) Execute the following command
    httpmon http://acadapps1/confirmactionlletters/ > httpmon.out.txt
    2b) Review the following files and send them back to me in an email
    httpmon.out.txt
    httpmon_test.log

    3) httpmon_test.log will indicate what the monitor is getting back when making the HTTP request
    3a) If the diagnostic utility succeeds in getting the URL then it is most likely an authentication issue when the Agent is running from the default user account. You will need to authorize the account on the web server or run the Agent under a different account with sufficient privileges (administrative) to perform other normal operations.
    ==========

    ==========

    Test the following in your environment until you also see an authorization challenge in a browser
    - Uncheck the value "Automatically detect settings" in IE and save
      -- Exit out of all instances of IE (use task manager to verify iexplore.exe is not running)
      -- Test the URL again with the updated settings in IE
    -  Create a new local user account on the computer and use IE to test the URL
    -  Use a different web browser (Firefox, Chrome) make sure the proxy settings are all off
    -  Try a web browser from a different computer, different user
    -  Check the settings of IIS on the webserver to verify it is configured the way you expect it to be

       Related Products:  
       
    1. BMC ProactiveNet Performance Management Suite

     


    Article Number:

    000091849


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles