Phurnace - Installer failed with libjvm.so message

Version 2
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    BMC BladeLogic Application Release Automation - Standard for WebSphere Business Applications


    APPLIES TO:

    BMC BladeLogic Application Release Automation - Standard for WebSphere Business Applications



    PROBLEM:

     

       

    Customer problem:

       

    On Linux 64 bit the installer for phurnace did not come up. Below is trace snippet:

       

    $ ./ARASInstaller-LINUX-3.7.1.13305-deliver-build-ARA3.7.1.bin

       

    Preparing to install...

       

    Extracting the JRE from the installer archive...

       

    Unpacking the JRE...

       

    Extracting the installation resources from the installer archive...

       

    Configuring the installer for this system's environment...

       

     

       

    Launching installer...

       

     

       

    /libjvm.so'.mp/install.dir.10891/Linux/resource/jre/lib/i386/server

      

     


    SOLUTION:

     

    Legacy ID:KA325246

      
       

    This happens when the bundled JRE is not compatible with System/OS JRE. Use the LAX_VM argumant to specify a valid JRE on the system:

       

    $ ./ARASInstaller-LINUX-3.7.1.13305-deliver-build-ARA3.7.1.bin LAX_VM <other JAVA path>

       

     

       

    For example:

       

    $ ./ARASInstaller-LINUX-3.7.1.13305-deliver-build-ARA3.7.1.bin LAX_VM /bmc/local/apps/BladeLogicARA/java/bin/java

      

     


    Article Number:

    000065970


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles