TrueSight Capacity Optimization (TSCO) - The startup scripts of the OS are not starting bgssd process on RHEL. (no bgssd or bgsagent running after server reboot).

Version 3
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    BMC Performance Assurance for Virtual Servers


    COMPONENT:

    BMC Performance Assurance


    APPLIES TO:

    BMC Performance Assurance 9.5.02 and onwards release for RedHat7 Operating system Install.



    PROBLEM:

    Checking the service daemon status from the below command show this as failed.
    # journalctl -u bgssd.service
    Jan 14 09:41:30 clm-pun-020261.bmc.com systemd[1]: Starting SYSV: Starts the BMC Performance Assurance Service Daemon in standalone mode...
    Jan 14 09:41:30 clm-pun-020261.bmc.com bgssd[23426]: Starting Perform Service Daemon: [FAILED]
    Jan 14 09:41:30 clm-pun-020261.bmc.com systemd[1]: bgssd.service: control process exited, code=exited status=255
    Jan 14 09:41:30 clm-pun-020261.bmc.com systemd[1]: Failed to start SYSV: Starts the BMC Performance Assurance Service Daemon in standalone mode.
    Jan 14 09:41:30 clm-pun-020261.bmc.com systemd[1]: Unit bgssd.service entered failed state.
    Jan 14 09:42:24 clm-pun-020261.bmc.com systemd[1]: Starting SYSV: Starts the BMC Performance Assurance Service Daemon in standalone mode...
    Jan 14 09:42:24 clm-pun-020261.bmc.com bgssd[23485]: Starting Perform Service Daemon: [  OK  ]
    Jan 14 09:42:24 clm-pun-020261.bmc.com systemd[1]: PID file /var/run/bgssd.pid not readable (yet?) after start.
    Jan 14 09:47:24 clm-pun-020261.bmc.com systemd[1]: bgssd.service operation timed out. Terminating.
     
    But the service is up and running
    [root@clm-pun-020261 ~]# ps -ef|grep bgssd
    root      7241  7135  0 09:21 pts/0    00:00:00 grep --color=auto bgssd

      perform  10348     1  0 Jan15 ?        00:00:00 /etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -s 2>/dev/null 1>/dev/null

     


    CAUSE:

    Redhat7 changed how system startup is handled. The old methods still work. The service daemon gets started at system startup. Looks like redhat7 changed how they do startup and a new file and commands will have to be done for redhat7 during install.


    SOLUTION:

    This will be fixed in later releases for the install scripts as per QM001913037 .

    Workaround:
    1. Create the following file /usr/lib/systemd/system/bgssd.service with this content
    [Unit]
    Description=BMC Performance Assurance Service Daemon
     
    [Service]
    Type=forking
    ExecStart=/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -s 2>/dev/null 1>/dev/null
    ExecReload=/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -s 2>/dev/null 1>/dev/null
    ExecStop=/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -k 2>/dev/null 1>/dev/null
     
    [Install]
    WantedBy=multi-user.target

    2. Move /etc/rc.d/init.d/bgssd to a safe place if this does not work for you.
    3. Stop the currently running bgssd with command
    /etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -k
    4. Refresh the services with command
    systemctl daemon-reload
    5. Check to see if the services will start on reboot
    systemctl start bgssd.service
    6. Check if service daemon start
     ps -ef | grep bgssd
    You should see
    /etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -s 2>/dev/null 1>/dev/null
     
    You can also see if you can telnet to the service daemon port
    telnet localhost 10128
    type some stuff
    You should get and SDPACK back
    Example:
    # telnet localhost 10128
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    ljlkjlkjkl
    SDPACKConnection closed by foreign host
     
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Problem is customer have RHEL 7 machine.
    We added suppport for RHEL7 machine for standalone BPA service for 10.7

    Here are the steps.
    Important make sure follwing steps are done via root user & only for RHEL7 systems

    1.chkconfig --del bgssd
    2.su - ${INSTALL_OWNER} -c "/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -k"
    Here ${INSTALL_OWNER} = Patrol User

    3.copy contents of following file in to new file called bgssd.startup.redhat7
    You can do vi bgssd.startup.redhat7

    >>>>>>>>> File Start >>>>>>>>>>>>
    #
    # @(#) bgssd
    #

    # Service Daemon stand alone mode system start up script
    #
    # Copyright (c) 2016 by BMC Software.
    # All rights reserved.
    #

    #optional port override
    #bgs_test_bgssd=10128
    #export bgs_test_bgssd
    ETCDIR=/etc/bgs/SD

    [Unit]
    Description=BMC Performance Assurance Service Daemon
    After=network-online.target network.service

    [Service]
    Type=forking
    Restart=on-failure
    TimeoutSec=5min
    KillMode=process
    IgnoreSIGPIPE=no
    GuessMainPID=no
    RemainAfterExit=no
    ExecStart=/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -s
    ExecStop=/etc/bgs/SD/bgssd.exe -d /etc/bgs/SD -k

    [Install]
    WantedBy=multi-user.target
    >>>>>>>>> File End >>>>>>>>>>>>

    Now copy this file to /usr/lib/systemd/system folder via following command: 
    cp bgssd.startup.redhat7 /usr/lib/systemd/system/bgssd.service

    Now simply run following commands:
    4.systemctl /usr/bin/systemctl enable bgssd
    5./usr/bin/systemctl daemon-reload
    6./usr/bin/systemctl start bgssd

    This will make sure bgssd process is started after reboot 

    The installer returning to 1, it was because when we run via patrol installer its give 0 and explicitly returns 1 all the time. so the ans is 1 is our success code so its always returns to 1. if we see in the setup.sh. So, Our installer always returns 1. Patrol Installer returns 0. 
     
    bgs processes not running after install or reboot : we need to go in the root account and run the b1config*.sh script. (for running explicitly the perform agent we need to run the b1.config file by root user as off if you are doing it via patrol then patrol agent will take care of it.) 

    Collector not starting without manual intervention : It will only auto-start -J PERFORM_AGENT_START_UNIX=True 

    You can apply the start script for RHEL 7 its attached to the KA.

     


    Article Number:

    000245684


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles