Patrol Agent hostname registered in the TSIM Console shows up with extra whitespace and extra characters causing issues with the policies

Version 1
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    TrueSight Infrastructure Management


    COMPONENT:

    PATROL Agent


    APPLIES TO:

    TrueSight 10.x



    DETAILS:

    We are seeing a few Patrol Agent which were setup using the hostname showing additional information that is causing conflicts with policies.

    Example of the issue:
    The customer has one server named bmcaprod1:

     catalina:bmcaprod1_bmcuser# hostname
     bmcaprod1
     catalina:bmcaprod1_bmcuser# zonename
     bmcaprod1
     catalina:bmcaprod1_bmcuser#

    But in the TSIM/TSPS the is registered as:
     bmcaprod1.bmc.acp acp
    In TSIM/TSPS the agent is registered showing the FQDN plus a white space plus the word "acp" again

    Please verify the FQDN returned by the Patrol Agent is correct. One way to do this is in the TSPS Query PATROL Agent windows and the following PSL command
     print(gethostinfo(get("/name")));

    Command : print(gethostinfo(get("/name")));
    Example results :
    bmcaprod1
    12.3.45.60
    08/03/2017 16:36
    Command : print(gethostinfo(get("/name")));
    Results :
    bmcaprod2
    12.3.45.61
    The PatrolAgent is not sending the FQDN with space in it.

    It seems that the Agent config file may have some extra characters and/or spaces that may exist in the configuration file.
    Especially the two variables:

    AentSetup\integration\useFQDN
    "/AgentSetup/integration/publishHostName"

    We would like to take a look at how these variables are defined in the Agent configuration.
    The 'pconfig +get' info would help
    Please check these two files, /etc/hosts and /etc/resolv.conf, or send us a copy of them
    The entries in the hosts file suggest multiple NICs on the patrol agent box.

    ::1 localhost
    127.0.0.1 localhost
    ###11.3.2.212 bmcaprod1 bmcaprod1.acp bmcaprod1.bmc.acp
    10.1.43.40 bmcaprod1 bmcaprod1.acp bmcaprod1.bmc.acp
    13.2.3.444 bmcaprod1-nfs
    21.4.145 bmcaprod1-bkup
    12.2.4.432 bmcaprod1nfs 
    13.4.0.123 bmcaprod1bk

    Make sure the PATROL Agent is configured to use only 1 IP address with this rule:
    "/AgentSetup/BindToAddress" = { REPLACE = "<pick one of the above IP addresses>" },

    Check the output of $BMC_PATROL_HOST_DOMAIN_NAME  and verify that it is the same as what appears in the TSIM UI.
    For this example, we saw the BMC_PATROL_HOST_DOMAIN_NAME environment variable is setting incorrect domain name.

    The ultimate fix was to do the following:
    Stop the Patrol Agent and comment out the BMC_PATROL_HOST_DOMAIN_NAME environment variable in /Patrol3/patrolrc.sh S50PatrolAgent.sh file.

    If there are multiple servers where this file needs to modified, then set the /Agent Setup/hostDomainName pconfig variable with the right domain name and apply this configuration to multiple servers.

    Restart the PATROL Agent and this should clear up the issue



     


    Article Number:

    000134609


    Article Type:

    Product/Service Description



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles