TrueSight Server Automation(TSSA): UPI Installer fails with messages like the following: prerequisites failed for server (server01.bmc.com): 1. User {0} does not have privileges to perform the upgrade.

Version 1
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    TrueSight Server Automation


    APPLIES TO:

    BSA 8.9,x and 20.02 Upgrade via UPI on Linux appservers



    PROBLEM:

     

    UPI fails when doing upgrade with messages similar to:

      

    The following prerequisites failed for server (server01.bmc.com): 1. User {0} does not have privileges to perform the upgrade. Please set up read and write privileges to access the computer using the RSCD agent. 


     

     


    CAUSE:

    The UPI needs to be run as root


    SOLUTION:


    If you are using sudo or su to become root on the system running the UPI you should use the syntax:
    sudo su - or su - instead of sudo su or su

    And then run the setup.bin.

     


    Article Number:

    000229630


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles