TrueSight Middleware and Transaction Monitor : QPWMB receives credentials invalid and retrying error while connecting to the target Broker

Version 1
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    TrueSight Middleware Monitor


    COMPONENT:

    BMC Middleware and Transaction Management


    APPLIES TO:

    TrueSight Middleware Transaction Monitor TrueSight Middleware Monitor BMC Middleware and Transaction Management



    QUESTION:

    Unable to connect to broker : Receive Not authorized to connect to target integration node while initiating a connection to the broker.

    Below is the error:
    Unable to connect to broker <BROKER>: Not authorized to connect to target integration node (hostname:4001) as user 'wmb'.  The Integration Node has administration security enabled and the credentials used were invalid.. Retrying in 30000 milliseconds


     


    ANSWER:

    There are two possibilities for this occurrence.

    First verify if this is something related to either the username/password being incorrect. 

    - Open a browser and try using the same URL prompted in errors.
    Should be something like ("hostname:4001") and verify whether the same credentials work here to get into the URL.
    Note that the Port and hostname needs to be changed as per your configuration settings.
    - While trying to connect to URL, the authentication goes to the IBM login.
    - Therefore, if the credentials aren't working while trying to access via browser then you need to re-check if you're using correct the username/password which includes proper access as well. 

    (OR)

    If you are using the HTTP port and not HTTPs. Verify if the parameter or the preference of CMPAPIUseSSL is still set to true. So if it is set to use HTTP then it is still using the HTTP port and trying to use SSL for authentication and that is why the connection has failed.

    - Check if CMPAPIUseSSL is turned off or set to false.(You can verify this from the eaa.xml file)
    - If it has not been set, you need to stop the agent and extensions, then edit the eaa.xml file and add below under com.bmc.mmpa.wmb.monitor stanza. You will also find the other CMPAPI parameters under the same set of list.

    <PreferenceAttribute>       <PreferenceName>CMPAPIUseSSL</PreferenceName>       <PreferenceValue>false</PreferenceValue> </PreferenceAttribute>
      
    - Please start the agent and extensions once the above change is performed. 

    If the issue is still persists after the changes made as above, contact BMC Customer Support with the logs. 

     


    Article Number:

    000184590


    Article Type:

    FAQ/Procedural



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles