App Visibility – Can a lower version of an App Visibility Agent for Java or App Visibility Agent for .NET work with a higher version of the App Visibility Manager?

Version 2
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    TrueSight App Visibility Agent


    COMPONENT:

    App Visibility Agent for Java


    APPLIES TO:

    App Visibility Agent for Java App Visibility Agent for .NET App Visibility Portal App Visibility Collector App Visibility Proxy



    QUESTION:

    Can a lower version of an App Visibility Agent for Java or App Visibility Agent for .NET work with a higher version of the App Visibility Manager?

    Note: App Visibility Manager contains the App Visibility Portal, App Visibility Collector, and App Visibility Proxy.

    For example, an App Visibility Agent for Java version 10.7.00 connected to an App Visibility Manager version 11.0.00.


    ANSWER:

     

    Yes, the App Visibility Agent for Java or App Visibility Agent for .NET can work up to -2 version less than the App Visibility Manager version.  However, the official support is to have the App Visibility Agent on the same version as the App Visibility Manager.

    NOTE - The Java/.Net agent version cannot be higher than the App Visibility Manager.  This scenario is not supported.

     


    Article Number:

    000169159


    Article Type:

    FAQ/Procedural



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles