AIF dont show in SmartIT

Version 1
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    Remedy with Smart IT


    COMPONENT:

    Remedy with Smart IT



    PROBLEM:

    When clicked on button View custom form from SmartIT for AIF request, user get error "You don't have permission"
    This issue is not their when access using Administrator access.
     


    SOLUTION:

    This use case Identified as defect #SW00561080

    Workaround:

    This validation error is throwing an error because user don't have either of one permission.

    1. Contact People Admin.
    2. Contact Support Admin
    3. Contact People User

    This is an old implementation of AIS cross launch which still checks if user is Agent or not to show cross Launch. To fix the behavior we have two options..

     Grant a user either of above permissions.

    OR

    Overlay the workflow : SRS:SMT_AIFValidateIfUserIsAgent

    Qualification Trom  : 

    ('hasAssetPermissions' = "True") AND ('hasIncidentPermissions' = "True") AND ('hasPeoplePermissions' = "True") AND ('hasRequestPermissions' = "True") AND ('hasTaskPermissions' = "True") AND ('hasWorkOrderPermissions' = "True")

    Qualification To :

     ('hasRequestPermissions' = "True")


    Article Number:

    000172521


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles