BPPM remote administration console does not start "BMC-BSW000002E Login is not available. Failure to connect to server "

Version 4
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    ProactiveNet Performance Management Suite


    APPLIES TO:

    ProactiveNet Performance Management Suite



    PROBLEM:

     

    BMC Proactivenet Administration Console was installed on a remote server and gives the following error when attempting to login:
    BMC-BSW000002E Login is not available. Failure to connect to server <Server_Name>

    Starting a browser and logging in to the Operations Console with the server name, userid and password works fine.

     


    SOLUTION:

     

    Legacy ID:KA413988

      

    Start the remote admin console from the command line using the debug option:
    BMC_PROACTIVENET_ADMIN_HOME\admin\admin.cmd debug
    Then try to connect and when the error occurs, review the logs which can be found at:
    BMC_PROACTIVENET_ADMIN_HOME\admin\pronto\logs\debug\Admin.log
    BMC_PROACTIVENET_ADMIN_HOME\admin\pronto\logs\ProactiveNetAdmin.log

    If this error is seen:
    ERROR 06/10 08:17:31 jservlets [AWT-EventQueue-0] 360718 Exception:
    java.rmi.ConnectException: Connection refused to host: 127.0.0.1; nested exception is:
    Try adding the following to the hosts file on both the remote admin server and the server where BPPM is install:
    127.0.0.1 localhost

    Another idea is to check if JMX monitoring has been enabled on the BPPM/TSIM server.  For example:
    -bash-4.2# grep jmxremote pnjserver.conf
    COMDefine A=B -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=9020 -Dcom.sun.management.jmxremote.local.only=false -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djava.rmi.server.hostname=127.0.0.1
    COMDefine com.sun.management.jmxremote.port=8787
    COMDefine com.sun.management.jmxremote.ssl=false
    COMDefine com.sun.management.jmxremote.authenticate=false
    -bash-4.2# grep jmxremote pnagentcntl.conf
    COMDefine A=B -Dcom.sun.management.jmxremote -Dcom.sun.management.jmxremote.port=9010 -Dcom.sun.management.jmxremote.local.only=false -Dcom.sun.management.jmxremote.authenticate=false -Dcom.sun.management.jmxremote.ssl=false -Djava.rmi.server.hostname=127.0.0.1
    -bash-4.2# grep jmxremote pnrate.conf
    COMDefine com.sun.management.jmxremote.port=8686
    COMDefine com.sun.management.jmxremote.ssl=false
    COMDefine com.sun.management.jmxremote.authenticate=false

    By default, those entries are commented. Un-commenting them will lead to the symptom.  But r
    eplacing the loopback IP 127.0.0.1 in pnjserver.conf and pnagentcntl.conf with TSIM's own IP address will allow you to start Java admin console client and still keep JMX monitoring.

    If the above does not resolve the problem, please send in the debug logs mentioned for further review.

      
    Related Products:  
       
    1. BMC ProactiveNet Performance Management Suite

     


    Article Number:

    000074534


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles