Within the BMC Performance Assurance Unix Console, how can I define a transaction class or workload in Analyze? How do I use wildcards in selecting process and command patterns?

Version 2
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    BMC Performance Assurance for Servers


    APPLIES TO:

    BMC Performance Assurance for Servers



    QUESTION:

     
       Wildcards can be used for pattern matching when choosing processes/process patterns for Transaction Classes and Workloads in Patrol Perform for Unix Analyze.  
       
        
    • TrueSight Capacity Optimization Linux console 10.5, 10.3, 10.0 
    •   
    • TrueSight Capacity Optimization Windows console 10.7 
    •   
    • BMC Performance Assurance for Microsoft Windows Servers  9.5, 9.0
    •   
    • BMC Performance Assurance for Unix  9.5, 9.0
    •   
    • Windows/Unix
    •  


    ANSWER:

     

    Legacy ID:KA305271

      

    To create an Analyze commands file (*.an) with transaction classes and workloads defined, follow these instructions:

    Step 1

      


    Start the Managing Console GUI and Select the Analyze module.

    Step 2

      


    Open an existing Analyze commands file with File => Open Commands. To create a new Analyze commands file, see Chapter 3 of the BMC Performance Assurance Implementation Guide for Unix and Linux or BMC Performance Assurance Implementation Guide for Windows Servers for more information on setting up a new Analyze commands/workload definition file.

    Step 3

      


    Run Analyze to process the collected data by selecting the green arrow. Analyze must first process an interval of data so that the "Browse Commands" and "Browse Processes" lists are populated when setting up a Transaction Class.

    Step 4

      


    Once Analyze finishes processing the data, select Transaction Classes to create a new transaction.

    Step 5

      


    Select Edit => Create => Independent

    Step 6

      


    Enter a name for the transaction class in the appropriate field.

    Step 7

      


    Under "Include Process Name Patterns" (located under the "Include" tab in 7.2.00), wildcards can be setup to catch all processes in the data that match a pattern. For example, to place all processes/commands with a reference to the string 'w1234' into the same transaction use the following pattern string:

    ".*" ".*w1234.*"

    The above command will pick up any process name (the first ".*"), and any command string which includes 'w1234' (".*w1234.*"). If the following processes were running on the node being processed by Analyze, they would be included in this transaction class:

     

      
              oracle       "ora_arch_w1234"
            oracle       "ora_ckpt_w1234"
            oracle       "ora_dbw0_w1234"
            oracle       "ora_lgwr_w1234"
            oracle       "ora_pmon_w1234"
            oracle       "ora_reco_w1234"
            oracle       "ora_smon_w1234"
     
      
      


    If there are other scripts running which access this oracle instance, they would get picked up, too.

      

    A more specific specification if you only want to select oracle processes would be 

      

     

      

    "oracle" "w1234"

      

     

      

    Alternately, the "Browse Processes" or "Browse Commands" shows all Oracle processes. "Browse Processes" shows the full process name while "Browse Commands" only shows the single process command name. Processes can be selected from these lists for inclusion into a transaction class. We highly recommend choosing the command from the "Browse Commands" list as an alternative to typing the string to avoid possible typo or formatting problems.

    Step 8

      


    Click the small gray box next to the "Auto-create Workload" label (under the "General" tab using the 7.2.00 console).

    Selecting the small gray box should cause it to turn green, and Analyze will automatically create an associated workload for this transaction class.


    Step 9

      


    Select Okay
     

      
      Step 10
      


    Select File => Close to return to the Analyze module main window.

    Step 11

      


    Save the file with File => Save or Save As.

    Step 12

      


    Run Analyze to re-process the data and generate the appropriate transaction classes and workloads.

    Step 13

      


    Once Analyze completes, view the Workload Composition Report to confirm the workloads have been generated:

    Report => Text => System => Common => Workloads => Composition

     

     


    Article Number:

    000031281


    Article Type:

    FAQ/Procedural



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles