DWP - Troubleshooting Survey/Comment/Bell/Mail Notification issues

Version 9
    Share This:

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    MyIT Digital Workplace


    COMPONENT:

    MyIT


    APPLIES TO:

    18.05 and beyond



    QUESTION:

    What do I need to check when surveys/email/comment notifications are not being fired on DWP?


    ANSWER:

     

    NOTE:

    SRM/ITSM notifications are not part of this troubleshooting list. That configuration is set in another Product: AR Server/Apps side of Remedy.



    Prerequisites:

    -Make sure that your SMTP ports are open on your LB, server Firewall, ACL and that your SMTP is working properly.
    -If this is a server group environment, make sure that only one server is set as master and only one has notificationPoller Enabled under connect-dwp.properties

     

      

    Primary DWP server

      

    #master.server=false
    master.server=true
    NotificationPoller.ENABLED = true

      


    Secondary DWP server
     

      

    master.server=false
    #master.server=true
    NotificationPoller.ENABLED = false

      

    -Make sure your DWP hostname has a valid ip set under the machine's host field.
    -If you are using an alias- make sure alias, loadbalancer, hostname, fqdn and ip address are correct and can be resolved correctly.




    CHECK LIST 


    1) First thing would be checking whether surveys are in enabled or not, per

      

    https://docs.bmc.com/docs/display/dwpadv1802/Configuring+email+notifications
    https://docs.bmc.com/docs/srm91/defining-behavior-rules-for-surveys-609065442.html

     

      


    2) Then you need to make sure that under connect.properties ( MyIT/DWP external conf folder)  you have the right SMTP settings:
         Here's an example.

      
       

    smtp.host=mailhost.calbro.com //for gmail use: smtp.gmail.com
    smtp.port=25
    smtp.account=dwp@calbro.com
    smtp.pwd=calpass

    if you are using Google SMTP
    Make sure you have this

    mail.smtp.ssl.enable=true and using port 465

      
      


    Note: This change requires a Tomcat Restart


    3) Go to  http://YourDWPServer:9000/dwp/admin/configuration/email.html

      
       
    • Make sure you have a valid email address on the Sender field

    •  
    • On the backend URL, make sure that you have  http:server:port OR if you have a custom URL/alias, it should look like this:

      

           http://sendmysurvey.com:9000/dwp

    If you do any updates on this, restart the DWP Tomcat,too.

      

     

      

    4) Edit JVM Settings for you MyIT Tomcat.  Having low memory values will prevent notifications from going out. Minimum recommeded is 6144m, Initial and Maximum values should always match.

      

     

         
     
      
       5) Please check if AR server(s) and DWP server(s) have the same Data/Time configured so they all are in sync.


    7) If you still face issues after doing all of the above, then collect UX/DWP on debug log and contact BMC support, please.  

     


    Article Number:

    000162833


    Article Type:

    FAQ/Procedural



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles