BSA: Error when logging into BSA Console or BLCLI - target service url in Session Request message does not match my URL: service:appsvc.bladelogic:blsess://server:9841 != service:appsvc.bladelogic:server.example.com:9841

Version 2
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    BladeLogic Server Automation Suite


    APPLIES TO:

    BMC BladeLogic Server Automation Suite



    PROBLEM:

     

    The following error message is displayed to the user and written to the appserver log when attempting to login to BSA from either the Console or the BLCLI: 

      
    20 Nov 2012 05:30:30,615] [Client-Connections-Thread-1] [WARN] [Anonymous:Anonymous:XX.XX.XX.XX] [Client] target service url in Session Request message does not match my URL: service:appsvc.bladelogic:blsess://server>:9841 != service:appsvc.bladelogic:blsess://server.example.com:9841
       

     

     


    CAUSE:

    The blasadmin "ValidateRequestUrl" setting is set to True on the Application Server. See the following explanation of this setting from the BSA documentation:


    SOLUTION:

     

    Legacy ID:KA388364

      

     
    The blasadmin ValidateRequestUrl setting is set to True on the Application Server. See the following explanation of this setting from the BSA documentation:

    https://docs.bmc.com/docs/display/public/bsa85/Recommendations+for+Application+Servers+of+type+Configuration

                                 

     

    If set to true, the Application Server verifies that its own address appears in the list of request URLs encoded in the session credential.

    For Application Servers in a load balancer environment or otherwise using an alternate URL besides the appserver hostname, take into account the type of traffic that you are load balancing:

          
           
    • If you are load balancing only authentication traffic (that is, connections to the AuthServiceURL), but are not load balancing traffic to the configuration server (that is, to the AppServiceURL) or not using a custom AppServiceURL, set this parameter to true.
    •      
    • If you are load balancing all traffic — to both the AuthServiceURL and the AppServiceURL — or setting a AppServiceURL that is different from the hostname of the appserver, set this parameter to false, as the client sends its request to the load balancer, and not to the configuration server that receives the connection request.
    •     
      
      

     


    Article Number:

    000092323


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles