In Control-M/Enterprise Manager Exception Alert window, received warning "XAlert sent to EM: 32007 Failure while trying to get active Control-M <DataCenterName> Maximum Days Retained Log and Output. using defaults from systemParameters.xml.

Version 1
    Share:|

    This document contains official content from the BMC Software Knowledge Base. It is automatically updated when the knowledge article is modified.


    PRODUCT:

    Control-M/Enterprise Manager


    COMPONENT:

    Control-M/Enterprise Manager


    APPLIES TO:

    Control-M/Enteprise Manager 9.0.00 and above Control-M Workload Archiving 9.0.00 and above



    PROBLEM:


    In Control-M/Enterprise Manager Exception Alerts window,  the following warnings appearing multiple times on a daily basis

    ########### 
    1208_09:26:13.945 [WARNING] T@43-CtmDataRefresh XALert sent to EM : 32007 Failure while trying to get active Control-M <DataCenterName> Maximum Days Retained Log and Output. using defaults from systemParameters.xml. took 209ms XAlertService::alertEM 

    1208_16:35:05.437 [WARNING] T@43-CtmDataRefresh XALert sent to EM : 32007 Failure while trying to get active Control-M <DataCenterName> Maximum Days Retained Log and Output. using defaults from systemParameters.xml. took 181ms XAlertService::alertEM 


    ########### 


    CAUSE:

    CAR00165639 - Archive failed to reconnect to CMS in order to get Maximum Days Retained Log and Output


    SOLUTION:

     

    To resolve this warning message, need to 

    a)  increase the number of polling retries the Control-M Configuration Server (CMS) try to get this information from the CMS 
    b)  increase the sleep time (in milliseconds) between polling retries
    c)  change the interval of checking the Control-M Server system parameters once every 23 days instead of once a day


    Here are the steps:

    1) On Workload Archive server, navigate to <EM_HOME>/archive/config directory

    2) Backup and edit the SystemParameters.xml file 

    3) Change the value of these 3 parameters shown below

    ======== The Default values are as followings for these 3 parameters ===========

               <Parameter>
                    <Name>fetch.ctmserver.data.availability.polling.retries</Name>
                    <Value>5</Value>
                    <SelectedType>Integer</SelectedType>
                    <Description>number of polling retries in order to get Control-M Maximum Days Retained Log and Output</Description>
               </Parameter>

                <Parameter>
                    <Name>fetch.ctmserver.data.availability.polling.sleep.between.retries</Name>
                    <Value>100</Value>
                    <SelectedType>Integer</SelectedType>
                    <Description>sleep time (in milliseconds) between polling retries in order to get Control-M Maximum Days Retained Log and Output</Description>
                </Parameter>

                <Parameter>
                    <Name>fetch.ctmserver.data.availability.interval</Name>
                    <Value>1440</Value>
                    <SelectedType>Integer</SelectedType>
                    <Description>refresh interval (in minutes) of Control-M Maximum Days Retained Log and Output. "0" will disable the entire feature of getting Control-M Maximum Days Retained Log and Output</Description>
                </Parameter>


    ==== TO THE FOLLOWINGS ====


                  <Parameter>
                    <Name>fetch.ctmserver.data.availability.polling.retries</Name>
                    <Value>10</Value>

                    <SelectedType>Integer</SelectedType>
                    <Description>number of polling retries in order to get Control-M Maximum Days Retained Log and Output</Description>
                </Parameter>
               
                <Parameter>
                    <Name>fetch.ctmserver.data.availability.polling.sleep.between.retries</Name>
                    <Value>500</Value>

                    <SelectedType>Integer</SelectedType>
                    <Description>sleep time (in milliseconds) between polling retries in order to get Control-M Maximum Days Retained Log and Output</Description>
                </Parameter>

                <Parameter>
                    <Name>fetch.ctmserver.data.availability.interval</Name>
                    <Value>33200</Value>

                    <SelectedType>Integer</SelectedType>
                    <Description>refresh interval (in minutes) of Control-M Maximum Days Retained Log and Output. "0" will disable the entire feature of getting Control-M Maximum Days Retained Log and Output</Description>
                </Parameter>
    -----------------
     
    4) After the change, recycled the Workload Archiving Server component from the Control-M Configuration Manager (CCM).


    Additional information:

    To suppress this alert fully, please refer to Knowledgebase Article mentioned below to disable it by setting the Control-M/Enterprise Manager System parameter XAlertsDisableMsgIDs with the value 32007.

    000111541 - How to configure XAlertsDisableMsgID system parameter in order to suppress specific message IDs on Exception Alerts console?

     


    Article Number:

    000148735


    Article Type:

    Solutions to a Product Problem



      Looking for additional information?    Search BMC Support  or  Browse Knowledge Articles